Ubuntu 16.04 lts hosts

Discussion in 'Installation/Configuration' started by adamjedgar, Apr 29, 2017.

  1. adamjedgar

    adamjedgar Member

    Hi guys,
    just completed an install however i am really not sure about how to setup my /etc/hosts file correctly.
    This is sitting on a Google Cloud Platform Compute Engine Instance.
    ISPConfig was installed using the automated standard script.

    FQDN is "mydomain.com.au" (obviously this isnt the real domain I am using)
    hostname is "goanna1"
    my internal ip address is localhost goanna1.mydomain.com.au goanna1
    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopbackfe00
    ::0 ip6-localnetff00
    ::0 ip6-mcastprefixff02
    ::1 ip6-allnodesff02
    ::2 ip6-allroutersff02
    ::3 ip6-allhosts metadata.google.internal metadata

    when i run the command "sudo hostname" it returns
    when i run the command "sudo hostname -f" it returns

    1. I am trying to work out how my /etc/hosts file should read as i am not sure about the ip addresses i am using above? (excluding the google one)
    2. I am also unsure of whether or not i need to add the external ip address into this file?
    3. Do i need an additional record for the goanna1.mydomain.com.au at my registrar or is the A record for mydomain.com.au pointing to server external ip address enough for isp config?
    4. Finally, when i attempted to log into ISPConfig admin area using https://goanna1.mydomain.com.au:8080 i get an error...
    "server DNS address could not be found. DNS_PROBE_FINISHED_NXDOMAIN"
    Have i done something wrong in my setup as the only way i can log into ISPConfig admin is to use https://mydomain.com.au:8080?
    (instead of https://goanna1.mydomain.com.au as outlined in the install documentation)

    I am able to access https://goanna1.mydomain.com.au:8080 from a mobile device but not from desktop pc. I am stumped about this one too.
    I have A records at the registrar for both goanna1.mydomain.com.au and mydomain.com.au pointing at my server external ip adress. Is this correct or should i only have a single A record pointing at server?
    Last edited: Apr 29, 2017
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    I spotted you are using your localhost ip instead of your internal ip. I think according to the tutorials you should use goanna1.mydomain.com.au goanna1, instead of goanna1.mydomain.com.au goanna1.

    I am not sure about number 2 and 3 though as for me, it will depends on whether that server name - goanna1.mydomain.com.au - is accessible publicly. You will need to add the dns for it if it isn't.
  3. adamjedgar

    adamjedgar Member

    Yes i am not sure about whether or not it should accessible publicly?
    It is going to be a webhosting server linked with whmcs for automatic provisioning of websites for clients.
    Whmcs is on a different server
  4. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    You may also access your ISPC via its ip e.g. https://ISPCServerIP:8080. Try to clear the cookies/caches in your pc browsers as well.
    Last edited: May 1, 2017

Share This Page