Ubuntu 6.06 LTS during ISPConfig MySQL root password error...stuck??

Discussion in 'General' started by Randall Hoffman, Jan 16, 2007.

  1. Randall Hoffman

    Randall Hoffman New Member

    The Perfect Setup Ubuntu 6.06 LTS Server
    Problem with ISPConfig installation. Everything has worked fine except the mysql root password section of ISPConfig.

    Please enter your MySQL server: localhost
    Please enter your MySQL user: root
    Please enter your MySQL password: xxxxx ERROR 1045 (28000): Access denied for user 'root'@locahost' (using password: YES) The provided MySQL password is wrong!

    I have reset the MySQL password using http://ubuntu.flowconsult.at/en/mysql-set-change-reset-root-password/ and still I can't get past this. I see this has happened to a few others but I can't seem to get past it. Any help you could provide is very much appreciated.
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you connect to MySQL when you run
    mysql -u root -p
  3. Randall Hoffman

    Randall Hoffman New Member

    Okay, I have found a solution. I dont know if this is the correct one or not, but it did allow me to install ISPConfig.

    I restarted the entire installation from the beginning.
    The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake)
    When I got to:
    Page 4 10 MySQL
    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h server1.example.com -u root password yourrootsqlpassword

    I skipped the second entry "mysqladmin -h server1.example.com -u root password yourrootsqlpassword"

    Then I proceeded with everything else. Now it is up and running. I wonder why the second line is even needed ?

    Thanks for your help.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Its needed. But you can change this easy after you installed ISPConfig.

    Please install the phpmyadmin addon, login to phpmyadmin and make sure that there is a password set for all root user accounts in mysql.
  5. The General

    The General New Member

    Same error for me as well!

    Strange you get this error, i get it as well but on Fedora core 4 install. Could anyone tell us why we get this error and what we have to do to stop it happening "Till" - "Falko" ???
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This error occurs when you enter the wrong mysql password, user or host in the ISPConfig installer.

Share This Page