uebimiau webmail problem

Discussion in 'Installation/Configuration' started by rosa hsiao, Oct 15, 2006.

  1. rosa hsiao

    rosa hsiao New Member


    I can send and receive my webmail this morning, but when I come back this afternoon,my uebimiau webmail gives me the following error message:

    Warning: fsockopen() [function.fsockopen]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php on line 66

    Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:110 (Unknown error) in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php on line 66

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php:66) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 64

    I have no idea how the error happens. I have tried to restart both the server and the gateway firewall device, but the error message is still the same.

    So far,I am using FC3+POP3+Postfix+Ispconfig+uebimiau and I can send and receive my email with "outlook express" by now.

    Can anyone tell me what to do or how to check my system to solve the problem?

  2. Hans

    Hans Moderator Moderator

    Hi Rosa,

    There where some people with the same problem.
    What seams to help is:

    restart apache with the command:

    /etc/init.d/httpd restart

    (i only don't know if you're running Uebimiau on port 81 or 80)

    If that does not help try to restart bind as well with the command:

    /etc/init.d/named restart

    If my suggestions do not work, please check you mail.log file to find related errors.
    Last edited: Oct 15, 2006
  3. rosa hsiao

    rosa hsiao New Member

    Hi Hans,

    I am using uebimiau at port 81. I have restarted httpd and named as you told me and the rusult is still the same. But, I find that the Ispconfig services are all displaying "offline". I am trying to restart all the services,but somehow I can't get it "online",not even shutting down and restarting the server.

    Do you know how to get all the Ispconfig services "online" via command line?
  4. Hans

    Hans Moderator Moderator


    Of course i can tell you how to startup the services:
    The commands to startup the most important ones are:

    /etc/init.d/postfix start
    /etc/init.d/httpd start
    /etc/init.d/mysql start
    /etc/init.d/named start
    /etc/init.d/saslauthd start

    To startup ISPConfig itself:
    /etc/init.d/ispconfig_server start

    (instead of start you also can use the commands restart or stop).

    I hope these services will startup again, but i have to say that they should startup automaticly after a reboot. You did not change your Hostname/IP-addresses?

    About your Uebimiau problem again:
    I found out that your the errors can appear after changing the IP-address of your server or your PHP-version.
    Your Uebimiau errors suddenly appear, did you make any changes or updates the day before?

    A good starting point for finding your problems is reading the log files.
    Try to find related errors in your lof files and report them here.

    We will try to help you.
    Last edited: Oct 15, 2006
  5. rosa hsiao

    rosa hsiao New Member

    Hi Hans,

    I have restarted all services as you told me,including rebooting the Ispconfig server. But,when I login Ispconfig web interface,the services under the Management tab are still "offline" as the attached images file.

    I did't change any ip/hostname recently. And I can send or receive email viia outlook express,which means that pop3 110 and smtp ports 25 are working just fine. Do you know the exact steps to uninstall Ubemiau webmail application under Ispconfig interface and reinstall it again without influencing existing maiboxes of all users?

    Attached Files:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Reinstalling ISPConfig and UebiMiau wont help at all to fix your misconfiguration.
    The problem is that all your services are not listening to localhost anymore.

    Please post the conetent of the file /etc/hosts
  7. rosa hsiao

    rosa hsiao New Member

    Hi Hans,

    I checked my /etc/hosts and found that there was no localhost definition. I don't know why the line was missing suddenly. After modifying the file and rebooting the server, all Ispconfig services came back to "online" as usual and I am able to use webmail as well.

    Thanks for your hint and help very much.
  8. Hans

    Hans Moderator Moderator

    Till mentioned the solution, not me, but i am happy that your server is up and running again.
  9. rosa hsiao

    rosa hsiao New Member

    Hi Hans,

    Please say "Thanks" to Till for me,too. You guys are really genius!
  10. Hans

    Hans Moderator Moderator

    One more thing:

    Maybe it is more secure to turn on your servers firewall.
    (In the picture you've sent it is turned off).

    Something to consider. ;)
  11. rosa hsiao

    rosa hsiao New Member

    Hi Hans,

    I already have a gateway as firewall in front of the server. Does it conflict with Ispconfig's firewall rules or should I just leave Ispconfig's firewall "off"?
  12. Hans

    Hans Moderator Moderator

    Ok, i see.
    In general firewall after can cause conflicts indeed.
    If you have a Gateway firewall already, your current settings are ok.
    This means, you do not have to turn on your ISPConfig firewall.
  13. rosa hsiao

    rosa hsiao New Member

    Then,I will keep Ispconfig's firewall "off". Thanks for your suggestion.

Share This Page