Unable to modiify site parameters

Discussion in 'Installation/Configuration' started by gimi, Jul 31, 2006.

  1. gimi

    gimi New Member

    I would like to increase the number of Max. Domain for a site.
    I got systelmaticaly the error message :
    "Your changes cannot be saved because this item is currently being updated. Please try again later."

    Any idea about ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check the ispconfig logfile for errors:

  3. gimi

    gimi New Member

    OK- now is working

    After changing some parameters in an other site (under ISPConfig I have 4 sites), the modification of parameters into my site is no more blocked.

    Thanks Till.
  4. jockstrap

    jockstrap New Member

    I got this too as it seems as a result of a but in the number of domains allocation...

    V2.2.5 on Debian 3.1 perfect install.

    I created a domain with and allocation of 2 domains.
    When I went to create a 2nd alias domain to the site it came up with an error saying I have exceeded my allocation for domains - but I had not!

    My stats for that site said 1 domain of 2 - so I tried to increase the site allocation to 3 domains when it came up with the "site in use" message as per the begining of this thread!

    So there appears to be 2 bugs in V2.2.5

    1) what ever a site's domain allocation is, you can only have up to 1 less than that allocation. ie: if 5 domains allowed - you can have 4.

    2) when you try to allocate more domains than your limit - and error is produced (which is normal) but this error produces a LOCK on the site which is seemingly freed when you edit another site!

    Falco and Till - any fixes for these bugs ?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a bug. You counted just the co-domains, but ISPConfig counts the total domains of the website. In your case 1 main domain + 4 co-domains = 5 domains overall in this website.

    The lock is a feature and not a bug, it has been introduced in ISPConfig 2.2.5 to avaid database corruption when you try to edit a website that is currently processed by the ISPConfig server process. The lock is removed automatically as soon as the processing of the website has been finished.
  6. jockstrap

    jockstrap New Member

    Thanks till for your reply but;

    1) for the domain (I set to 2 domains allowed) and then setup the site - www.mydomain.com - that's it! Then later when I tried to add a co-domain (which would now equal 2) it would not let me untill I made the domain allocation 3 or higher.

    2) The lock stays permanently! was there hours and even after a reboot. It only was removed when I modified another site on the server..
  7. falko

    falko Super Moderator ISPConfig Developer

    When you create the web site www.mydomain.com, ISPConfig automatically creates the Co-Domain mydomain.com, so you already have two domains.

    When there's a lock, what's the output of
    ls -la /root/ispconfig
  8. jockstrap

    jockstrap New Member

    Falko - the lock is easy to reproduce. Simply set number of domains for a site to 2 and then try to add a co-domain. It will compalin as expected that you can not add it but the lock will be left!

    Here is the output..

    total 124
    drwxr-xr-x 9 root root 4096 2006-08-13 07:25 .
    drwxr-xr-x 5 root root 4096 2006-08-12 12:54 ..
    -rwxr-xr-x 1 root root 54012 2006-08-12 12:55 cronolog
    -rwxr-xr-x 1 root root 9673 2006-08-12 12:55 cronosplit
    drwxr-xr-x 12 root root 4096 2006-08-12 12:41 httpd
    drwxr-xr-x 12 root root 4096 2006-08-12 12:55 isp
    -rw-r--r-- 1 root root 8 2006-08-13 07:25 .old_path_httpd_root
    drwxr-xr-x 6 root root 4096 2006-08-12 12:36 openssl
    drwxr-xr-x 6 root root 4096 2006-08-12 12:49 php
    drwxr-xr-x 4 root root 4096 2006-08-12 12:55 scripts
    drwxr-xr-x 4 root root 4096 2006-08-12 12:55 standard_cgis
    drwxr-xr-x 2 root root 4096 2006-08-12 12:55 sv
    -rwx------ 1 root root 9389 2006-08-12 12:55 uninstall

Share This Page