Unacceptable TLS Certificate - Raspberry Pi - solved

Discussion in 'Linux Beginners' started by EricN, Feb 19, 2022.

  1. EricN

    EricN New Member


    I’m a new networking student at a local community college. I tried to install an app on my Raspberry Pi but kept getting a “Unacceptable TLS certificate” error when I tried to install it. After several hours, I found a fix. I don’t know if anyone is going through the same issue but here is how I fixed it.

    I’m taking a Linux/Unix class this semester and broke out the old Raspberry Pi (Maker: Vilros) to have a computer to try the commands that we are learning. I have the Pi set up to automatically start as a games emulator. If you have the same Pi, just exit out of the emulation program. When you are at the command line, to start the GUI OS I type “xstart” and the GUI OS starts.

    To find out your version type: “uname -srm” without the quotes. When I started this morning, my Linux kernel was:

    Linux 4.19.42-v7+ armv71

    I was able to install Wireshark with a tutorial from this website. I also wanted to have a list of stocks running on my desktop and found one called Markets from flathub dot org website. I do not know anything about this website and will run an antivirus later on to be safe. I just wanted to install the app for stocks, so I tried:

    “apt install flatpack”

    Next their website says to “add the Flathub repository” (Not sure exactly what this does, more research for later on). So they want you to run:
    “flatpack remote-add - -if-not-exists flathub [see their website, I can't post links]” – note that between the 2 “-“ there is no space but MS Word likes to make it a solid dash so I put a space there to make it apparent.

    This is the step where I got the error message. The error message was something like: “Unable to load summary from remote flathub: Unacceptable TLS certificate”

    At first I thought this was a certificate issue. I tried to update the certificates:
    “sudo dpkg-reconfigure ca-certificates” (No quotes)

    I thought this might update the certificates. No luck as I was still getting the same error message. I decided to try and update the kernel and see if that would fix the issue. I was worried about losing my games but they are still on the system. Here are the steps I took (don’t use the quotes):

    “sudo apt update”
    “sudo apt dist-upgrade” – this updates the Pi
    “sudo apt clean” – cleans up your files
    “sudo reboot” – reboots the Raspberry Pi

    After updating, I now have:
    Linux 4.19.66-v7+ armv71

    I tried to reinstall the Flatpak with the following steps:
    “sudo apt install flatpak” – installs a flatpak package but not sure what this step does?
    “sudo flatpak remote-add - -if-not-exists flathub [see their website]” – Adds the repository?
    NOTE: I did not get the error message this time!
    “reboot” – rebooted my machine

    With the error message gone, I now needed to install the app on the Pi:
    “flatpack remote-ls flathub - -app”
    “flatpack install flathub com.bitstower.Markets” – I think this installs the app
    “flatpack run com.bitstower.Markets” – this runs the app.
    NOTE: I had to use the command line to install the app.

    You will need to open another terminal as this program will tie up the terminal you used to run it. For me, I hit Control+C to end the program.

    So it turns out that an update was needed and the Certificate was not the issue (this is my guess). Now I have a Raspberry Pi that can run as a game emulator, let me try out the Linux commands, and next I will add some networking tools (ie Wireshark) so maybe I can test some stuff at home as we learn about Linux in class.

    I’m hoping that this might help someone that is running into the same problem that I was running into. The Raspberry Pi is a cool and portable computer. I’m not really sure what area I am going to get into for Network Administration as I am just getting into the field. However, if you are in the field and know of a program that I can add to my Raspberry Pi that might help me out with interviews later on please let me know. I am starting with Wireshark and will add another program when I get comfortable with that.


Share This Page