Uncaught mysqli_sql_exception: Data truncated for column 'warnvirusrecip' at row 1

Discussion in 'Installation/Configuration' started by jendab, Feb 1, 2023.

  1. jendab

    jendab New Member


    I'd like to ask you for help with my issue... updates to the webserver are not sent, jobqueue is stuck, dbispconfig has probably some issues...

    [email protected]:~# /usr/local/ispconfig/server/server.sh
    01.02.2023-15:10 - WARNING - There is already a lockfile set, but no process running with this pid (175558). Continuing.
    PHP Fatal error: Uncaught mysqli_sql_exception: Data truncated for column 'warnvirusrecip' at row 1 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:302
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(302): mysqli_query()
    #1 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(339): db->_query()
    #2 /usr/local/ispconfig/server/lib/classes/modules.inc.php(171): db->query()
    #3 /usr/local/ispconfig/server/server.php(180): modules->processDatalog()
    #4 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 302

    I have multiserver set-up, dedicated ispconfig control panel, web, mail, SQL, NS...

    I have installed purly new and clean (minimal install) debian 11 for the new/second web server.
    The only thing I installed there is zabbix agent and ISPconfig in multiserver way.

    Configuration Updates from control panel were working for this server, but then, they stopped for some reason.
    more info:
    ISPCONFIG version - main server (control panel) as well as the new clean webserver is: 3.2.9
    * 7 /usr/bin/php7.4 74 manual mode
    * 6 /usr/bin/php-cgi7.4 74 manual mode

    Server version: 10.5.18-MariaDB-0+deb11u1 Debian 11

    MariaDB [(none)]> SELECT @@SQL_MODE, @@GLOBAL.SQL_MODE;

    ANy idea how to resolve this please?
    I tried to remove tables from dbispconfig and recreate them from scratch, didn't work...

    It might be related to PHP version as I tried to add additional versions into the new web server from control panel, but not sure...changing of PHP version(alternative from OS) didn't work either.

    thank you so much
    kind regards
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to compare the spamfilter_policy database table of master with the one of this slave system. Seems as if data was saved successfully in this table on the master but it can't be saved on the slave server.

Share This Page