Unknown column 'fastcgi_php_version' in 'field list'

Discussion in 'General' started by Jean-Francois Leblanc, Aug 18, 2021.

  1. Version: ISPConfig 3.2.5

    I'm trying to create a new website on my host, didn't have this issue before the upgrade, but this is the first time I add a website since the website.
    I did lookup the error, but couldn't find this specific one. If I try to create a website with no PHP selected, I get this message. Any PHP option, and it always comes back with the "fastcgi_php_version" issue.
    Can someone assist with this issue?
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Sounds like your sql schema didn't update correctly, as that column was dropped. What version did you update from? Did you see any errors when you updated? You could try restoring the backup made before updating and run through the update again to try to find where things went wrong, or simply compare your current schema with the incremental sql update files to see what changes need made (see install/sql/incremental/upd_*.sql, and probably only need to look at the last few files, depending on what version you updated from).
  3. I did update from 3.2.2 to 3.2.5 so I did skip a two versions. I'll take some time and compare the update sql files and see what got missed. I did not get any error messages specifically, the update went smoothly.
  4. Just a quick follow-up on the solution. As mentioned by Jesse, It looks like one of the SQL updates failed to apply during the installation, and I must have missed the error. I located the update file by going to the directory incremental folder, and searched for
    grep -w fastcgi_php_version *
    I found the offending lines in the upd_0031.sql file.
    I looked at the file, and compared it to the SQL database, and I noticed the alter command at the end was no applied.
    I manually ran "ALTER TABLE `web_domain` ADD `fastcgi_php_version` VARCHAR( 255 ) NULL DEFAULT NULL;" in phpmyadmin, and it resolved my issue.
    Thank you
    zenny and till like this.
  5. zenny

    zenny Member

    Thanks for pointing to the solution. I also encountered the same issue. Your post helped me to resolve.

    But I did in the command line as follows::

    # mysql -u root -p
    Enter password:
    Welcome to the MariaDB monitor.  Commands end with ; or \g.
    Your MariaDB connection id is 71243
    Server version: 10.5.12-MariaDB-0+deb11u1 Debian 11
    Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.
    Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
    MariaDB [(none)]> use dbispconfig;
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    Database changed
    MariaDB [dbispconfig]> ALTER TABLE `web_domain` ADD `fastcgi_php_version` VARCHAR( 255 ) NULL DEFAULT NULL;
    Query OK, 84 rows affected (0.018 sec)
    Records: 84  Duplicates: 0  Warnings: 0
    MariaDB [dbispconfig]> flush privileges;
    Query OK, 0 rows affected (0.002 sec)
    MariaDB [dbispconfig]> quit
    Hope this could be helpful to those who encounters the similar issue and would like to resolve in command line. Cheers.

Share This Page