Update manager won't work

Discussion in 'Installation/Configuration' started by yvovandoorn, Oct 20, 2005.

  1. yvovandoorn

    yvovandoorn New Member

    I tried installing the webmail.pkg and phpmyadmin pkg and I get the following error:

    The following error occurred:

    Installations Anweisungen nicht gefunden: /home/admispconfig/ispconfig/temp/e8edd7029d4c49d5ad46bb9b6c9127a9/package.ins

    Thinking it is a problem with the directory, i cleared out the dir and tried again, but no luck.

    I tried installing by uploading them (downloading them to my local HD and then using the upload function) and the URL where they are at available for download.

    There are no modifications to this installation other then that it is running dovecot instead of UW IMAP (per the perfect setup guide).
  2. yvovandoorn

    yvovandoorn New Member

    Further investigation reveals that ISPConfig doesn't expand / extract the package contents:

    [root@disgruntled-dutch web]# cd /home/admispconfig/ispconfig/temp/9c0f010ca57c4cf0318ba8a6f4ec32fa/
    [root@disgruntled-dutch 9c0f010ca57c4cf0318ba8a6f4ec32fa]# ls
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    In the directory /home/admispconfig/ispconfig/tools/unzip/ is a binary of the unzip program, this seems not to work correctly. Try to execute it on the commandline and check if you get a error message. If you get an error, try to find an unzip that works on your system and copy it to this directory. Make shure it is executable by the user admispconfig.
  4. yvovandoorn

    yvovandoorn New Member

    The unzip utility seems to be working fine:

    [root@disgruntled-dutch unzip]# unzip
    UnZip 5.51 of 22 May 2004, by Info-ZIP. Maintained by C. Spieler. Send
    bug reports using http://www.info-zip.org/zip-bug.html; see README for details.

    Usage: unzip [-Z] [-opts[modifiers]] file[.zip]

    • [-x xlist] [-d exdir]
      Default action is to extract files in list, except those in xlist, to exdir;
      file[.zip] may be a wildcard. -Z => ZipInfo mode ("unzip -Z" for usage).

      -p extract files to pipe, no messages -l list files (short format)
      -f freshen existing files, create none -t test compressed archive data
      -u update files, create if necessary -z display archive comment
      -x exclude files that follow (in xlist) -d extract files into exdir

      modifiers: -q quiet mode (-qq => quieter)
      -n never overwrite existing files -a auto-convert any text files
      -o overwrite files WITHOUT prompting -aa treat ALL files as text
      -j junk paths (do not make directories) -v be verbose/print version info
      -C match filenames case-insensitively -L make (some) names lowercase
      -X restore UID/GID info -V retain VMS version numbers
      -M pipe through "more" pager
      Examples (see unzip.txt for more info):
      unzip data1 -x joe => extract all files except joe from zipfile data1.zip
      unzip -p foo | more => send contents of foo.zip via pipe into program more
      unzip -fo foo ReadMe => quietly replace existing ReadMe if archive file newer
      [root@disgruntled-dutch unzip]#

      Further more I decided to download the webmail package...

      [root@disgruntled-dutch unzip]# wget http://www.ispconfig.org/downloads/webmail.pkg
      --10:39:12-- http://www.ispconfig.org/downloads/webmail.pkg
      => `webmail.pkg'
      Resolving www.ispconfig.org...
      Connecting to www.ispconfig.org||:80... connected.
      HTTP request sent, awaiting response... 200 OK
      Length: 907,003 (886K) [text/plain]

      100%[==========================================>] 907,003 198.79K/s ETA 00:00

      10:39:22 (185.80 KB/s) - `webmail.pkg' saved [907003/907003]

      [root@disgruntled-dutch unzip]# unzip -t webmail.pkg
      Archive: webmail.pkg
      testing: webmail.tar.gz OK
      testing: package.ins OK
      testing: nav.inc.php OK
      No errors detected in compressed data of webmail.pkg.
      [root@disgruntled-dutch unzip]#
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    When you tried to install the package with the update manager, are you shure you selected the correct method (upload or URL) for the datasource? If you are not shure, please try the installation again with selecting upload when you want to upload the .pkg file ur URL when you specified the URL to the .pkg file.
  6. yvovandoorn

    yvovandoorn New Member

    I double checked what I was doing and I am still unable to install the package.

    I tried uploading it and specifically browsing for the file and selecting the option, it fails

    I tried downloading it directly from ispconfig.org making sure i have the correct option selected.

    Also in case it comes up, I have tried Firefox 1.0.7, 1.5, IE 6, Safari 2.0.1... all report the same thing.
    Last edited: Oct 22, 2005
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you changed anything in the ISPCOnfig config file manually? The file is: /home/admispconfig/ispconfig/lib/config.inc.php

    Are the following lines present and have exactly this content:

    $go_info["server"]["dir_trenner"] = "/";
    $go_info["server"]["server_root"] = "/home/admispconfig/ispconfig";
    $go_info["tools"]["unzip"] = $go_info["server"]["server_root"].$go_info["server"]["dir_trenner"]."tools".$go_info["server"]["dir_trenner"]."unzip".$go_info["server"]["dir_trenner"]."unzip";
  8. joostvdl

    joostvdl Member


    I have the same problem here. Both via upload and URL are not working. I have installed the latest version (2.1.0) on Ubuntu 5.10
  9. falko

    falko Super Moderator ISPConfig Developer

    I've just checked this and installed webmail and phpMyAdmin using the Update Manager in ISPConfig (the latest version, 2.1.0), and it is working without any problems.

    Is it possible that the quota for the user admispconfig is full on your system? Can you post the output of
    repquota -avu | grep admispconfig
  10. yvovandoorn

    yvovandoorn New Member

    Ok the lines are definitely not in exact order but rather all over the place.

    You have a blank after the "$go_info["tools"]["unzip"] =", this is what mine has.

    and no, i haven't touched the config file.

    $go_info["tools"]["unzip"] = $go_info["server"]["server_root"] . $go_info["server"]["dir_trenner"] ."tools".$go_info["server"]["dir_trenner"]."unzip".$go_info["server"]["dir_trenner"]."unzip";    
    here is the output for the quota check:

    [root@disgruntled-dutch lib]# repquota -avu | grep admispconfig
    admispconfig -- 18132 0 0 1067 0 0
  11. yvovandoorn

    yvovandoorn New Member

    So any ideas yet?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Not really, Ive tested it today on a freshly installed system and it works here. If you want to try to install the packages manually (means unpacking and copying the ´content on the shell) i can post some instructions.
  13. joostvdl

    joostvdl Member

    I looked at the files on the server. It looks like if the binary files that are installed with de ispconfig installation are NOT working.

    When I run unzip from the /home/admispconfig/ispconfig/tools/unzip directory it gives
    bash: /home/admispconfig/ispconfig/tools/unzip/unzip: No such file or directory

    Also not working:
    (and maybe I missed some)

    The system I tested is Ubuntu 5.10

    This makes update not working but also logging of websites is not working
  14. yvovandoorn

    yvovandoorn New Member

    sure i guess i will have it do the manual way.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a 64 Bit Linux?
  16. joostvdl

    joostvdl Member

    Yes. It is a P4 with EMT and HT (so it is 64bit)
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you installed a 32Bit linux or 64 Bit linux on it? On a 32Bit linux the binaries should work.

    You can use the zip and unzip from Ubuntu.

    Installation (untested!):

    apt-get install zip unzip
    cp -f /usr/bin/zip /home/admispconfig/ispconfig/tools/zip/zip
    cp -f /usr/bin/unzip /home/admispconfig/ispconfig/tools/unzip/unzip
    chown admispconfig:admispconfig /home/admispconfig/ispconfig/tools/zip/zip
    chown admispconfig:admispconfig /home/admispconfig/ispconfig/tools/unzip/unzip

    The tcpserver is not nescessary in ubuntu.
    spamc should work as it was compiled on your system during installation. spamc is working if you call it and dont get any message back and have to stop the process with strg + c.

    For cronolog i'am serching for a solution.
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Installing Cronolog:

    apt-get install cronolog
    cp -f /usr/sbin/cronolog /root/cronolog
    cp -f /usr/bin/cronosplit /root/cronosplit
  19. joostvdl

    joostvdl Member

    In the latest version the problem isn't solved yet. Also the ssl problem isn't solved. Why isn't that taken with the new update?
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem cant be solved. If we change the binarys that they work on your server, it will break 99% of the other systems. Sorry, but for now you will have to copy or symlink the binaries from your system again.

Share This Page