Update to 2.2.0 killed my data

Discussion in 'Installation/Configuration' started by retran, Mar 3, 2006.

  1. retran

    retran New Member

    I updated to 2.2.0 from 2.1.2 using ./setup from the 2.2.0 tarball per instructions. At least I thought following the instructions. All my websites still work, ftp and email still works, and so does the DNS. I noticed a problem when I tried to log in my ISPConfig panel. The username admin did not exist or work. I checked the mysql database for my ISPConfig installation... and all the tables (except dns_*, doctype, sys_dep, sys_modules, and sys_nodes) had been truncated completely, as in all the rows were erased! All my usernames, isp, reseller account info seems to be completely gone.
    Yes I know in hindsight I should have backed this database up completely before the upgrade (my last ISPConfig upgrade went through without a hitch so I was caught off guard).

    Constructive questions I have now are..

    Does ISPConfig by default leave any backups nightly, etc that I can find to rebuild my ISPConfig database?

    What could have gone wrong to cause the ISPConfig set to erase all my tables? (So this doesn't happen to others, or to me again.)

    Is there a way to get a default data set of ISPConfig database without having to run the setup fresh, if I cannot find a backup I have performed manually?
    Last edited: Mar 3, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Therea re no automatic nightly backups. But ISPConfig stores a backup of you database, and ISPConfig files when you start an update. Please check your /tmp folder, if there are any tar.gz files with the database.

    Did you get any errors during installation and run the installer a second time without restoring the backups in /tmp first?

    Please check if you had the backups in your /tmp folder as described above.
  3. retran

    retran New Member

    Two things I checked...

    I checked the /tmp directory and found no .tar.gz files (just a bunch of files prefixed "sess_"). Are there any other directories I can check for a dump of the database? This system is the latest release of Debian.

    I did not get any apparent errors during installation, and only ran it once. I did notice a "mysqldump: Got errno 28 on write". I have not run anything else since. The following is cut & pasted results from the end of the install procedure if they give any clue.

    Connected successfully to db ispconfig
    mysqldump: Got errno 28 on write
    Restarting some services...
    Stopping mail transport agent: Postfix.
    Starting mail transport agent: Postfix.
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
  4. falko

    falko Super Moderator Howtoforge Staff

    That's the error - the installer couldn't create the SQL dump of the old ISPConfig database which is later on used to copy the existing values to the new ISPConfig database... Maybe your hard disk is full? Please post the output of
    df -h
  5. Joffar

    Joffar New Member

    I think i got the same thing when I upgraded. I didnt notice it rieght away, but when trying to connect to the website I got the same error 28. I am not sure if anything got messed up or not, but a restart fixed the issue with the /root being full... One thing I noticed was that now ISPconfig insist on http://www.blumonkey.org instead of just http://blumonkey.org Any ideas where I can edit so i can get this back to just http://blumonkey.org ?
    Last edited: Mar 3, 2006
  6. falko

    falko Super Moderator Howtoforge Staff

  7. retran

    retran New Member

    That might have been the problem, my tmpfs being full at the time. What happens now? Is all my ISPConfig database lost forever or is there a way to rebuild it? Some script to make the process easier to glean usernames & such from the httpd.conf file? What's the best way to go about it?
  8. falko

    falko Super Moderator Howtoforge Staff

  9. retran

    retran New Member

    Actually, from what I can tell my existing old ISPConfig database is of little worth becasue all the tables in it are empty. The old one was wiped out per this Install process because the ISPConfig upgrade did not halt when it encountered the mysqldump error! Instead it continued on with wiping my good database info away without a dump of data to repopulate it.

    I guess a fact I want to make clear, is that I could not get the tar.gz file of the database dump made during the upgrade process because it was never created because the /tmp device was full at the time of the upgrade.

    With all this in mind, is my only option to rebuild ISPConfig from scratch, and then manually add and configure all my websites manually? Is there nowhere else to look? Is this one of those hard lessons learned that before upgrading ISPConfig I should have made a manual backup as well?
    Last edited: Mar 6, 2006
  10. falko

    falko Super Moderator Howtoforge Staff

    Yes, that's the only option. The database is the heart of ISPConfig.

Share This Page