Updated my Debian, MySQL failed to restart

Discussion in 'Installation/Configuration' started by morganew, May 31, 2013.

  1. morganew

    morganew New Member

    after many months of smooth operation, I went to update Debian to the final stable version of 6.

    I ran aptitude, selected update, looked to see if there were any obvious package problems, none turned up.

    during upgrade, mysql failed to restart. I have attempted to get mysql re-instealled but dpkg is failing with a dependency error

    Here's the output of my recent apt-get attempt:

    /install_ispconfig# apt-get install mysql-server mysql-client libmysqlclient-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    mysql-client is already the newest version.
    mysql-server is already the newest version.
    The following package was automatically installed and is no longer required:
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
    2 not fully installed or removed.
    Need to get 3,113 kB of archives.
    After this operation, 12.4 MB disk space will be freed.
    Do you want to continue [Y/n]? Y
    Get:1 http://mirrors.kernel.org/debian/ stable/main libmysqlclient-dev i386 5.1.49-3 [3,113 kB]
    Fetched 3,113 kB in 2s (1,207 kB/s)             
    (Reading database ... 49083 files and directories currently installed.)
    Removing libmysqlclient15-dev ...
    Processing triggers for man-db ...
    Selecting previously deselected package libmysqlclient-dev.
    (Reading database ... 48994 files and directories currently installed.)
    Unpacking libmysqlclient-dev (from .../libmysqlclient-dev_5.1.49-3_i386.deb) ...
    Processing triggers for man-db ...
    Setting up mysql-server-5.1 (5.1.49-3) ...
    Stopping MySQL database server: mysqld.
    Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!
    invoke-rc.d: initscript mysql, action "start" failed.
    dpkg: error processing mysql-server-5.1 (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mysql-server:
     mysql-server depends on mysql-server-5.1; however:
      Package mysql-server-5.1 is not configured yet.
    dpkg: error processing mysql-server (--configure):
     dependency problems - leaving unconfigured
    Setting up libmysqlclient-dev (5.1.49-3) ...
    configured to not write apport reports
                                          configured to not write apport reports
                                                                                Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    As you can see it appears to be stopping mysql, then restarting before configuring, therefore it fails.

    is apt-get purge the recommended fix?
  2. morganew

    morganew New Member

    Problem solved.

    It turns out that the updated version of mySQL added the flag "skip-bdb" to the mysql config file in /etc/mysql/my.cnf

    check your syslog and look for the following error

    [ERROR] /usr/sbin/mysqld: unknown option '--skip-bdb'

    If you see this error, try the following fix. In your /etc/mysql/my.cnf, comment out the following line:

    # Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.

    to read:

    # Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.

    after making this change, I was able to do another apt-get install mysql-server and it all went smoothly.

    There may be some reason to NOT comment that switch out, but I was trying to solve the immediate problem. If my "fix" creates some downstream problem I haven't considered, please let me know here.
  3. tkausl

    tkausl New Member

    It looks like it want to disable an feature which isnt implemented lol
    BDB is only an engine like INNODB and MyISAM. If u dont need this, this isnt a problem.

Share This Page