Updating to Debian 12: Roundcube SMTP error

Discussion in 'Installation/Configuration' started by brainsys, Nov 23, 2023.

  1. brainsys

    brainsys Member

    My small (RPI/arm64) home server updated from Debian 10 to 11 without issues a couple of years ago. Repeating the update from Debian 11 to 12 using your tutorial appeared to go OK until I came to post an email from Roundcube. I get this error:

    SMTP Error (530): Failed to set sender "[email protected]" (Authentication required for RFC4409/MSA access.).

    I can email from the command line so SMTP appears to be working. It uses my ISP (Zen) mailserver but changing it to localhost didn't help.. During the upgrade I was asked if I wanted Roundcube to update the database. First time I answered 'Yes". I then reverted and next time answered "No". Same result. Reverting again back to Debian 11 and everything is OK.

    This is a test server as I need to update my public facing servers. But I can't till I can crack this. Any help appreciated.
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    I suspect the error comes from your ISP's mailserver, might want to check with them for some pointers?
  3. brainsys

    brainsys Member

    I agree it's coming from them. The issue is that the same /etc/roundcube/config.inc.php configuaration works under Bullseye but not Bookworm. There appear to be other instances of upgrading Debian 11 to 12 breaking Roundcube.

    As a workaround I tried using localhost but that won't authenticate either.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ahrasis and Th0m like this.

Share This Page