Upgrade Debian Whezzy to Jessie can't boot

Discussion in 'Installation/Configuration' started by Lupi, Feb 5, 2016.

  1. Lupi

    Lupi Member

    A 2 months ago I upgreded my servers to Jessie 8.0. It's worked nice. Yesterday I have updated to Jessie 8.3 from kernel 3.2.0-4 to kernel 3.16.0-4 but my web server can't boot. The another servers just works fine with new kernel.
    Gave up waiting for root device. Common problems:

    -Boot args (cat /proc/cmdline)
    -Check rootdelay= (did the system wait long enough?)
    -Check root= (did the system wait for the right device?)
    -Missing modules (cat /proc/modules; ls /dev)
    Then its go to shell initframfs....

    If I go back and boot from old kernel 3.2.0-4 then its boot normally.

    Any help????
  2. ericf

    ericf New Member

    I got this as well. Are you using vmware? It seems there are issue with vmware (maybe older versions) and kernels above 3.14
    In my case I removed all the problematic kernels, so it would boot by default the previous working kernel.
  3. Lupi

    Lupi Member

    No, I don't use vmware. It just worked nice with this kernel, until update. How to remove safetly this kernel, because by rebooting server choose 3.16.0-4?
  4. ericf

    ericf New Member

    Sorry for the late reply...
    I hope you find the solution, anyway, here is what I did, I just typed:

    apt-get remove linux-image-3.16.0-4-686-pae

    you can also type :

    dpkg-reconfigure "name of the kernel package you want to keep"

Share This Page