Upgrade from 2.2.0 to 2.2.1 - all profiles are missing

Discussion in 'Installation/Configuration' started by teleriddler, Apr 24, 2006.

  1. teleriddler

    teleriddler New Member

    I recently downloaded ISPConfig 2.2.1.

    I ran the upgrade as specified by extracting the tar.gz file and running ./setup. The upgrade took awhile but everything seemed to be fine. I enter my SSL information for certificate creation. When the setup completed successfully I logged into the ISPConfig admin interface. Login went fine and I verified the software version and it was show correctly.

    I went to look at my sites I had built and found that there was nothing listed in the ISP Manager interface. This is very troubling as my sites still physically exist on the server but I have no way to administer them. I was wondering if anyone else experienced this in an upgrade and how to fix it. It almost seems to me that the ispconfig db has information in it but it is just not being displayed.

    Any help would be greatly appreciated.

  2. falko

    falko Super Moderator Howtoforge Staff

    Did you make manual changes to the ISPConfig database before or after the update?
  3. teleriddler

    teleriddler New Member

    Nothing changed

    I did not make any changes to the ISPConfig database. Is there a way to downgrade. I have copies of the backups that the installer made in /tmp. I think I might have located a problem. My root / drive is only 5 GB big. The backups of ISPConfig filled it to almost 99% capacity. In the future it might be nice to prompt the installer for a location where he/she would like the backups to be created.

  4. teleriddler

    teleriddler New Member

    Problem solved


    So in desperation I decided to downgrade to 2.2.0. This went horribly wrong, I got most of the way through the install and then there was an error about a php-binary. So I followed some advice I found in other posts.

    I moved the ISPConfig-2.2.1.tar.gz file into /root. I then ran the install in exper mode as the user root.

    Now everything works fine. There must be an issue with running the installer as root but not running it from the /root directory. Hope this helps anyone else having this issue.


Share This Page