Upgrade from MySQL Server 5.1 to 5.5, Data in DB not the same?

Discussion in 'Installation/Configuration' started by iceget, Feb 27, 2016.

  1. iceget

    iceget Member

    hello community,
    i have today upgraded one of my testserver. before i have done a upgrade to mysql 5.5
    all websites works perfectly (in most case i have installed typo 3).

    after the mysql 5.5 upgrade, the data in the mysql databases have changed? can this be?
    why? i have double spaces (like <br><br>) and dataloss on each tables...
    what i can do that i get all databases working as with mysql 5.1 setup?

    can anybody help me?


    many greets, iceget
  2. ztk.me

    ztk.me Well-Known Member HowtoForge Supporter

    Did you do an exact copy as test environment, especially regarding the database configuration files?
    Have you different default locales set? How exactly did you copy the databases?
    Did you pay attention to innodb files and settings? If you didn't set some, make sure default values haven't change.
  3. iceget

    iceget Member


    I have used a backup for the test (1 day ago).
    I only have done a dist Upgrade froh Debian squeeze. Have tried the Upgrade with leaving the my.cnf default and one Try with New my. Cnf...

    After MySQL was upgraded from 5.1 to 5.5 (wheezy) i have the Problems with the database

    How can i check what is going wrong?

    I dont have Export and then after Upgrade a Import..

  4. ztk.me

    ztk.me Well-Known Member HowtoForge Supporter

    actually I don't see why there should be an issue - to save time I'd just try mysqldump from old database and restore to new and see if there are errors aswell.
  5. iceget

    iceget Member

    Hello ztk.me, thanks, i have tried this so, bot no success :(
    have done a fully mysql dump from mysql database, then i have done a upgrade and dist-upgrade (from squeeze to wheezy).
    after this steps from mysqlserver 5.1 to 5.5, i have this problems.

    have comapred the tables, the mysql database is correct...

    i have created (uploadet here) a screenshot from the typo3 page (squeeze / jessie). in upgrade step from squeeze to wheezy, i get the error.

    Attached Files:

  6. ztk.me

    ztk.me Well-Known Member HowtoForge Supporter

    You not only did a switch from 5.1 to 5.5 you did a migration from MySQL 5.1 to MariaDB 5.5
    I don't think that is recommended in any way. I think the howtos should be clearer about that. You don't just switch database software.

    So what happens if you use mysql 5.5 on the new system?

Share This Page