Upgraded php 5.1.6 to 5.3 = broken ispconfig3

Discussion in 'General' started by OvrFlote, Oct 16, 2009.

  1. OvrFlote

    OvrFlote New Member

    I recently upgraded php on my centos 5 server, for no other reason than Kohana required php 5.2 or later.

    Upgraded via remi to php 5.3, and then everything went sideways. I have lost mydns (will not start)
    I know this because yesterday I was able to log in to two seperate servers that were upgraded (php) but now today I cannot even sign into the ispconfig3 admin console.

    I am fairly noob, knowing only enough to be dangerous (to myself).

    If anyone has any advice it would be greatly appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely your PHP updates have overwritten some config files. Please download the latest ispconfig version and run the update.php script. choose "yes" when the installer asks you if you want to reconfigure the system.
  3. OvrFlote

    OvrFlote New Member

    Thank you

    I will give it a shot and let you know what happens.

    Thank you
  4. OvrFlote

    OvrFlote New Member

    Did the update

    After the update, I can now sign in to the ispconfig admin consoled. and it looks as though this solved my SMTP problem (service is online)

    However, MyDNS is still fudged. I cannot get mydns to stat or start.

    # dig @localhost myserver.com
    ; (1 server found)
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    # netstat -tap | grep dns

    # /etc/init.d/mydns start

    # /etc/init.d/mydns status

    at this point i would post my config file, but i have checked it 3 times and it is the exact same file as before the upgrade took place.

    Really hope you can help me out here. I am "behind the eight ball" on this one. Thanks
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    netstat -tap
    ? Any errors in your logs?
  6. OvrFlote

    OvrFlote New Member

    narrowing it down

    I have "un"- upgraded mydns from 1.2.8(remi repo) to 1.1.0 (site release) and this fixed mydns, but I am still having lots of problems. I checked httpd error_log and found these errors:
    PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 1232, referer: http://notmyrealdomain.com:8080/
    PHP Warning: date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead in /usr/local/ispconfig/interface/lib/classes/validate_dns.inc.php on line 272, referer: http://notmyrealdomain.com:8080/
    it is pretty well chalk full of php deprecated function calls in ispconfig

    if you still need netstat -tap let me know, but mydns is showing up in there now that i downgraded to the stable release.

    basically this is what is happening. i can restart apache (/etc/init.d/httpd restart), log into ispconfig and change settings, but after about 10 minutes, everything dies and i have to restart apache again. same is true for just looking at the site every 5 - 10 minutes of browsing screen just shows white website with nothing there, and i have to restart apache. but while i can access ispconfig, everything shows "Online" for services,
  7. falko

    falko Super Moderator ISPConfig Developer

    Lots of things have changed in PHP 5.3, it shows lots of warnings. You can change the error reporting level in your php.ini to suppress such warnings.

Share This Page