Upgrading ISPConfig from to 3.1

Discussion in 'Installation/Configuration' started by kerrsmith, Sep 28, 2016.

  1. kerrsmith

    kerrsmith Member

    I am planning on upgrading today (from to 3.1) and have been reading the tutorial for The Perfect Server - Debian 8.4 Jessie (Apache2, BIND, Dovecot, ISPConfig 3.1), in this tutorial there are several differences between my original setup and this new version.:


    Before I upgrade do I need to install the following parts to get my server ready?

    10.1 Install HHVM (HipHop Virtual Machine)
    11 Install Let's Encrypt
    18 Install UFW Firewall

    I did not do the parts above when setting up for the version as they are new to 3.1 I think.

    I will be making a full backup before I do any upgrade so I can revert back if anything unexpected happens but if the above looks like it is all I need to do I will go ahead and update.
    Last edited: Sep 28, 2016
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    I believe that's optional, only install it if you intend to use it. In my limited testing, the memory usage for a site running hhvm was ridiculous, so I've switched to php-fpm (ondemand).
    Definitely install letsencrypt. Again, it's optional, but it's easy/free ssl for all your sites, so do it! :)
    The old bastille firewall script does not support ipv6. Strictly speaking I think it might still work for ipv4; I don't know if there's an official stance (only ufw is now supported, or both), but things are definitely moving to ufw. It's not hard to switch an existing system (look up the steps, but it's something like: delete all firewall rules in ispconfig gui, remove the bastille script, install ufw, switch server config to ufw, then add firewall rules back).
  3. kerrsmith

    kerrsmith Member

    Hi Jesse,

    Thank you very much for help, I really appreciate it.

    I did the following to install UFW:

    Went to the firewall setting and deleted all the rules
    Waited for that job to complete
    Went to server config and chose UFW
    Waited for the job to complete
    Installed UFW
    Went to the firewall config and re-added the rules

    For Let's Encrypt I followed the instructions in the document in the first post, at the end it listed all my sites and said which to install to so I just clicked cancel.

    I then did ispconfig_update.sh and followed the instructions on:


    My only issue came at the end where I received the following errors:

    Restarting services ...
    Update finished.
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 21: -d: command not found
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: `else'
    /usr/local/bin/ispconfig_update.sh: line 4: ate.php: command not found

    Are these errors anything to be concerned about?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, see bugtracker.
  5. kerrsmith

    kerrsmith Member

    Hi Till,

    Thanks for letting me know - just in case anyone else is here with the same issue the bug tracker page for this is:


    The comments state that the reason for the error is that 'the script gets updated while it runs. The update should have worked' and that this is a non-critical error.
  6. mangia

    mangia New Member

    I upgraded to 3.1 and now the clients are not able to add/create new domain in DNS section or email domain in email section. (Actually they can add the domain, but in the list, the server field is empty)
    In DNS section, click on the "Records" tab leads to: "The selected server is not allowed for this account." error

    As I can see in the git, the error error_not_allowed_server_id was triggered and it seems that the server is not in authorized servers for this client. All templates are assigned with the server (single server configuration)

    Any ideas ?
  7. mangia

    mangia New Member

    Sorry... I found the problem... For some reason, the client and reseller templates was not assigned with the default server.
  8. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Something to check, I don't know "the answer" offhand - if the templates are set with the dns server, maybe try editing the client to make sure the template is set correctly and save again. Maybe even try a Custom template, and set the server there on one client and see if it works for that one client, just as a data point.
  9. mangia

    mangia New Member

    Exactly that was the problem. I didn't notice that email/db/dns section has the dedicated dropdown/multiselect field for servers.

    Thanks for your response
  10. davefrooney

    davefrooney Member

    Thanks for the info guys!
    I'm am doing my update in a multi-server environment tomorrow. I have been reading through the manual and I'm hoping the process goes smoothly. I am running a master server with multiple web and mail servers.
    From what I understand, I am supposed to update the master server first, is this correct?
    Is there anything else I need to take into account before updating?
    Thanks in advance,
  11. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Probably enable maintenance mode when you begin (disable when done), otherwise it's pretty much the same procedure over and again on each server. Make backups first, of course. :)
  12. davefrooney

    davefrooney Member

    Thanks for getting back to me. Another thing, I have the DKIM plugin installed, will this migrate all records in the build in DKIM?
  13. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    As I understand, the DKIM support in 3.0.5 is actually a backport of what's in 3.1, and it should upgrade without a problem.
  14. sunghost

    sunghost Member

    i will test the Upgrade from 3.1dev to 3.1 and ask myself if configs like in postfix amavis e.g which are customized will changed by the updater. Is that true?
    Last edited: Oct 20, 2016
  15. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    it depends on what changes you made, some would be preserved, and some would be overwritten. Eg. if you add new settings to postfix's main.cf, those should remain untouched; however if you changed any of the settings that are configured by ispconfig, your changes will be lost when you run the ispconfig updater (during the "reconfigure services" part). Backup your config first and you can follow up with any needed changes that were undone later.

    Also note for things like main.cf settings which ispconfig will overwrite, you can preserve your changes if you copy a "conf" file to "conf-custom" directory, and make your changes there. Eg. download the new ispconfig tarball and untar it and look under the install/tpl directory (or get the files from the web at https://git.ispconfig.org/ispconfig/ispconfig3/tree/stable-3.1/install/tpl) - then copy any of those you need to change to the corresponding conf-custom directory (sometimes under a conf-custom sub directory, depending on what file) and make your changes.
  16. sunghost

    sunghost Member

    Hello Jesse,
    and thanks for your reply. Must i run the reconfigure services part or is it not necessary? I read anywhere that it must run if i use lets encrypt. is that right? in which cases i have to run the reconfigure step of services, except i want to set e.g. a new port?
  17. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Yes, you must reconfigure services when upgrading 3.0.5 to 3.1.
  18. sunghost

    sunghost Member

    Hello Jesse,
    i have still Version 3.1dev installed. The Upgrade to latest 3.1 Patch1 is in the normal update way possible or should i consider something?
  19. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Yes, just run ispconfig_update.sh and choose the default 'stable' source.
  20. sunghost

    sunghost Member

    Hi Jesse,
    and sorry for answering so late. I now have time to go on and looked into "/install/tpl/" director. But i do not found the mentioned "conf-custom" directory. Should i create it, or is it missing in latest 1p1 Version?

Share This Page