Urgent: All Webs have no more quota left

Discussion in 'General' started by virtualweb, Mar 30, 2008.

  1. virtualweb

    virtualweb New Member


    please give me a hint what i could try to solve my following problem:

    Over night all Websites are over Quota - and no Mails were accepted anymore.

    As workaround i gave all Clients Tons of quota. The Mails can be accepted now.

    But none of the Website was really over the quota, for example:

    The Mail from ISPConfig says:
    Group: web27
    Used Storage Space: 317.23 MB
    Allocated Storage Space: 250.00 MB

    This does'nt accept mails, the error is:

    imapd-ssl: Failed to create cache file: maildir_lock (xxx)
    imapd-ssl: Error: Disk quota exceeded

    A manual du -hs as root gives: 149MB
    As admispconfig the du command returns 76MB

    AS this is a serious Problem and many Cleints are abused, i urge for help on this problem!
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    df -h
    repquota -avug
    ls -la /tmp

    Can you check if there are huge log files in the log directory of each web site?
  3. virtualweb

    virtualweb New Member

    Hi Falko,

  4. virtualweb

    virtualweb New Member

    For that example web (web27) In ISPConfig no user is marked as Admin, so the files in the web directory are owned by www-data

    l [B]/var/www/ | grep web27[/B]
    drwxr-xr-x 15 www-data                         web27 4,0K 2008-01-10 00:06 web27
    lrwxrwxrwx  1 www-data                         web27   14 2007-12-28 23:43 www.example.com -> /var/www/web27
    [B]l /var/www/web27/[/B]
    insgesamt 56K
    drwxr-xr-x  2 root                  root  4,0K 2006-07-24 12:39 bin
    drwxr-xr-x  2 www-data              web27 4,0K 2006-07-24 12:37 cgi-bin
    drwxr-xr-x  2 root                  root  4,0K 2006-07-24 12:39 etc
    -rw-rw-r--  1 root                  web27   36 2008-03-30 04:11 .htpasswd
    drwxr-xr-x  2 root                  root  4,0K 2006-07-24 12:39 lib
    drwxr-xr-x  2 root                  root  4,0K 2006-07-24 12:39 lib64
    drwxr-xr-x  5 www-data              web27 4,0K 2008-03-02 00:30 log
    drwxrwxrwx  2 www-data              web27 4,0K 2006-07-24 12:37 phptmp
    drwxr-xr-x  2 www-data              web27 4,0K 2006-07-24 12:37 ssl
    drwxr-xr-x  3 www-data              web27 4,0K 2006-07-24 12:39 user
    drwxr-xr-x  4 root                  root  4,0K 2006-07-24 12:39 usr
    drwxrwxr-x  3 example.com_office web27 4,0K 2006-07-24 12:55 var
    drwxr-xr-x 28 www-data              web27 4,0K 2008-01-10 00:06 web
    Is it mandatory that at least one user is marked as admin?

    Another web which is not working has an admin marked user and his quote is -1 ins ISPConfig, so i think it doesn't matter if no user is marked as admin.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    It is recommended that one user is the administrator of the website.

    Please set the quota limit of the website to a higher value or to -1. The quota of the website is the group quota and the quota of the administrator user is the userquota of the site.
  6. virtualweb

    virtualweb New Member

    I increased the quota limit of each website by 1gb. It works now but this is hopefully only a workaround?

    What permissions must the files/folders have for getting the correct quota Infos?

    If the real quota is smaller then 20% of what in the Statistics is shown, we must either increase the website by 20% or inform the customers when they have reached their real limit?

    Isn't there a better way to get this problem solved?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Why should this be a workaoround? According to your repquota output, everything is working correctly, just the quota was full.

    If the quota size is not shown correctly, you will have to reconfigure the du command to be executed with root permissions:

  8. virtualweb

    virtualweb New Member

    OK i reconfigured the du command, logged in as admispconfig and ran the command. (du -hs .)

    All Maildirs are not allowed to something:

    du: »./user/example.com_user/Maildir«: Keine Berechtigung (No Permission)

    I chmodded the Maildirs to 755 for testing, the du command then runs without the permission error.

    But when i change/add a user in ISPConfig all the permissions of the Maildirs in the corresponding web are reverted so that the du command will give the error above.


    The web uses "real" 450MB

    When i set the quota to the web to 600MB (or 1000MB or 1100MB) and send emails to this user i get them back with the error "disk quota exceeded".

    This is the mail system at host example.com.
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    For further assistance, please send mail to postmaster.
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
                       The mail system
    <[email protected]>
    (expanded from
        <[email protected]>):
    can't create user output file. Command output:
        /bin/cat: write error: Disk quota exceeded procmail: Program failure (1) of
        Rescue of unfiltered data succeeded procmail: Quota exceeded while writing
        ".Junk/tmp/1207122466.15616_1.HOSTNAME" procmail: Quota exceeded
    [ Delivery (message/delivery-status 7bit) not shown]
    I changed the quota to 1500MB and no quota errors appeared - everything works fine then.


    Is there any solution for this? Do i really must give the user a quota of 500MB even he only should have 250MB? All the alert Emails and Statistics would be obsolete?
    Last edited: Apr 2, 2008
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Everything is fine. Please do just what is described in the thread above. You can not test the du command as any login user on the shell manually as the sudo configuration is only for the admispconfig user!
  10. virtualweb

    virtualweb New Member

    Dear Till,

    thanks for your patience. I tried all of the above but nothing works for me, i must give 900MB Quota to a web which is only allowed to use 250MB. A lesser Quota results in exceeded quota errors.

    I can assign unlimited Webspace to all the webs and set the quota of the admin user to 5MB but this makes no sense - neither i receive warning mails nor i have an overview of the stats of the web.

    Am i the only one who has this problem?

  11. falko

    falko Super Moderator ISPConfig Developer

    Can you check the /tmp directory and also the logs directories of your web sites if there are large files/unused log files that can be deleted?
  12. virtualweb

    virtualweb New Member

    The /tmp directory is empty, the log directory is 30MB.

    This are the stats in ISPConfig
    Speicherplatz gesamt:  	5000 MB
    verbraucht: 	458.68M
    /lib64 	100K
    /cgi-bin 	4.0K
    /phptmp 	4.0K
    /ssl 	4.0K
    /var 	12K
    /bin 	1.2M
    /log 	30M
    /lib 	2.1M
    /user 	337M
    /web 	82M
    /etc 	12K
    /usr 	2.0M
    DB::MySQL 	5813.1k
    The web uses "real" 460MB

    I must give at leat 1200MB Quota to the web which is only allowed to use 600MB. A lesser Quota results in exceeded quota errors.
  13. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker; we'll check this.
  14. flipkick

    flipkick ISPConfig Developer ISPConfig Developer

    Hi virtualweb,

    I can't reproduce your problem.

    Your output of repquota:

    ..says the same as the notification mail:

    Both say, that web27 has exceeded its quota limit.
    To give web27 more than 250MB quota, change it in the ispconfig frontend in the settings for the website web27.

  15. Norman

    Norman Member HowtoForge Supporter

    I can confirm that I too get a lot more quota messages and full boxes with the latest patch.
    Seems to be due to the antivirus scanning but it has gone through the roof on this latest patch.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Please switch to Clamd instead of Clamscan:


    or use the Clamd from your Linux distribution.

    There has nothing been patched in ISPConfig, the problem is the latest ClamAV version that got even worse when it comes to deleting its own temp files.
  17. virtualweb

    virtualweb New Member



    for those with the same problem. i found out there was a backup of my www-directory in the /home directory.

    when logged in as admispconfig on the shell and type "du -hs" there are errors on some directories (.spamassassin and .Maildir) but the quota in ispconfig shows the correct size.

    so the quota command is system-wide and not only in /var/www/*

    now it is all correct, it was no error in ispconfig.

    thanks for the help!

Share This Page