URGENT DNS Problem - can't see DNS records any more

Discussion in 'Installation/Configuration' started by muekno, Jan 26, 2015.

  1. muekno

    muekno Active Member HowtoForge Supporter

    ISPConfig Multiserver Installation, Master Server and prime DNS open SuSe 12.3 latest patches, secondary DNS openSuSe 13.1
    until yesterday system running fine, did not add or check DNS Records sind weeks.
    Yesterday I updates server Servers from 12.3 to 13.1 with zypper, worked fine. Only on secondary DNS MySql would not start, tryed some things, no succes. as it was only secondary DNS. I deleted all entrys in ISPConfig Console for secondary DNS. The I deleted the Server itself in the Console (as recommanded by Till in another Thread where someone asked who to remove a webserver). The I set up a new Server with 13.1 following the relevant parts (for DNS Server) Tutorial for perfect server 13.1 and installed it in the system following the ISPConfig 3 manual. Works fine so long.
    Added all secondary DNS Entries for the secondary DNS Server.
    Would add are record to a domain in console, select domain OK, select records button, the button highlights, but no records will be listet still the domain entries are show.

    need help urgent

  2. muekno

    muekno Active Member HowtoForge Supporter

    Tried again after writing above, the records a shown aagrrh, but the the job queue still shows all jobs for updating secondary dns.

    I think I remember right, the client must be able to connect port 3306 mysql on the ISPConfig master, which it does as secondary server ist on an network over the internet
    Last edited: Jan 26, 2015
  3. muekno

    muekno Active Member HowtoForge Supporter

    Found the reason why job queue stops
    Replication failed. Error: (client) in MySQL server: (localhost) Incorrect integer value: '' for column 'created_at' at row 1 # SQL: REPLACE INTO client (`client_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`company_name`,`company_id`,`contact_name`,`customer_no`,`vat_id`,`street`,`zip`,`city`,`state`,`country`,`telephone`,`mobile`,`fax`,`email`,`internet`,`icq`,`notes`,`bank_account_owner`,`bank_account_number`,`bank_code`,`bank_name`,`bank_account_iban`,`bank_account_swift`,`paypal_email`,`default_mailserver`,`limit_maildomain`,`limit_mailbox`,`limit_mailalias`,`limit_mailaliasdomain`,`limit_mailforward`,`limit_mailcatchall`,`limit_mailrouting`,`limit_mailfilter`,`limit_fetchmail`,`limit_mailquota`,`limit_spamfilter_wblist`,`limit_spamfilter_user`,`limit_spamfilte.. on new secondary DNS slave

    How to fix

    Thanks for any help
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you use mysql or mariadb and which version do you use?
  5. muekno

    muekno Active Member HowtoForge Supporter

    mysql-comunity-server/client 5.6.12-7.2.2 latest on SuSe for 13.1 32 bit, can not run 64-bit (restriction of ESXi 4.x on my hardware) set to sql_mode=NO_ENGINE_SUBSTITUTION as of tutorial
  6. muekno

    muekno Active Member HowtoForge Supporter

    And now what shall I do?

    I just payed half year support
    I have postet problem to priority support now
    Last edited: Jan 27, 2015

Share This Page