urgent help with xserver please Thanks

Discussion in 'Desktop Operation' started by kadi, Mar 17, 2008.

  1. kadi

    kadi New Member

    I made a big mistake today, i changed the
    file X11/xorg.conf without making a backup
    for it, i was trying to correct the screen resolution,
    which i was having hard time with it every time it
    turns on, so i tried to fix the problem to start the
    GUI startx but for some hours now i didn't get anywhere,
    i tried dpkg-reconfigure and after 1/2 hour
    questions it gave me this message:
    "xserver-xorg postinst warning: overwriting possibly-customized configuration file; backup in/etc/X11/xorg.conf.20070729111015."
    second time i got priority set to -1 cannot exec.
    then i started the server and got the same message i used to get:
    your xserver is not configured right it will be detected. I push OK
    nothing happen, i tried 4 CD's rescue and Knoppix everything possible
    I can't get into the server, i need a big help on this one please.
    I even tried to overwrite the file with a backup orginal one and got:
    access denied & i login as root, try to delete what i added and
    save it access denied also, like noway of doing anything.
    tried to make it read write doesn't work either.
    when i try the command startx --logverobose i got:
    connection refused cannot connect to x server
    No such process server error error (111)
    exec of /usr/bin/Xorg failed
    Thanks very much any help will be appreciated.
    Last edited: Mar 17, 2008
  2. kadi

    kadi New Member

    I have to add somthing

    hello again
    I manage from a single user boot on grub to
    make the /etc/X11/xorg.conf read-write and
    open it correct the screen resolution but this
    didn't change the boot, i heard this file has a
    syslink with another xorg file, may be this is
    the reason that is not working if they are not
    the same unless the linked file updates itself
    i didn't get any reply so far and can't get
    into the GUI, each time i try i got a message:
    "your graphical interface is not configured
    correctly" in the xorg.conf the driver is 100%
    I am still trying hoping somebody will help me
    with this problem that put me Nowhere.
    Thanks in advance again :mad:
  3. falko

    falko Super Moderator Howtoforge Staff

    What's the output of
    ls -la /etc/X11
  4. kadi

    kadi New Member

    Thanks mr/Falko very much

    Hello mr/Falko
    Thanks very much i appreciate your reply,
    i been trying for a few days with no luck
    and for me it is not an easy job to start
    fresh again after all i did with your help
    to make the server stable, to make the
    story short:
    I ran this command of course from the
    cmd line and all i can see is :
    there is xorg.conf + alot of reconfiguration
    files with numbers at the end 32456789
    as a result of me trying to dpkg-reconfigure
    anothe 2 files xorg.save,save1 also most
    of those files include xorg.conf are rwxrwxrwx
    and i did that myself from the cmd also
    i was able to correct the /etc/X11/xorg.conf
    after i made the attributes to rw i used knoppoix
    also i download the nvidia TnT2 from their site
    and try to install it from the cmd line but
    there was an error: cannot fine kernel-source
    anyway i tried to let the installer connect
    tp download the kernel-source but says
    cannot connect! , i don't know why? the
    connection is working, sorry i can't remeber
    all the output because you know it is on dos
    screen and i can't print it.
    I am just NOwhere with the server, also i found
    out alot of people have the same problem
    with the xorg and nVidia card.
    I am trying as much as how many commands
    that i learned from you.
    I just wonder if i uninstall GDM and reinstall it again
    is that will make it better?
    Thanks alot very very much.:mad:
    Last edited: Mar 18, 2008
  5. o.meyer

    o.meyer New Member Moderator

    Hi kadi,

    try the following:

    First rename your xorg.conf to keep it as backup and to make sure that no xorg.conf exists.

    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
    After that create a new one.

    sudo dpkg-reconfigure -phigh xserver-xorg
    Hope that works for you.

    Best regards,

  6. kadi

    kadi New Member

    Thanks mr/Falko and thanks o.meyer

    To mr/Falko
    I used knippox and was able to copy my /etc/X11

    total 118
    drwxr-xr-x 19 root root 60 Mar 18 2008 .
    drwxr-xr-x 8 root root 540 Mar 18 19:39 ..
    lrwxrwxrwx 1 root root 13 Nov 17 2006 X -> /usr/bin/Xorg
    -rw-r--r-- 1 root root 3033 Dec 21 2006 XF86Config.in
    -rw-r--r-- 1 root root 1027 Feb 22 2006 XftConfig
    -rw-r--r-- 1 root root 884 Dec 5 2005 Xloadimage
    drwxr-xr-x 2 root root 2048 Jan 3 2007 Xresources
    -rw-r--r-- 1 root root 243 Dec 11 2001 Xserver.xserver-common-backup
    -rwxr-xr-x 1 root root 3340 Apr 2 2004 Xsession
    drwxr-xr-x 2 root root 2048 Jan 3 2007 Xsession.d
    -rw-r--r-- 1 root root 265 Nov 29 2005 Xsession.options
    -rw-r--r-- 1 root root 13 May 7 2006 XvMCConfig
    -rw------- 1 root root 616 May 4 2006 Xwrapper.config
    drwxr-xr-x 2 root root 6144 Jan 1 2007 app-defaults
    -rw-r--r-- 1 root root 13 Jan 4 2004 default-display-manager
    drwxr-xr-x 2 root root 2048 Jan 2 2007 fluxbox
    drwxr-xr-x 8 root root 2048 May 4 2006 fonts
    drwxr-xr-x 2 root root 2048 Jan 2 2007 icewm
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-3dlabs
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-8514
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-agx
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-fbdev
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-ggi
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-i128
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-mach32
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-mach64
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-mach8
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-mono
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-p9000
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-s3
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-s3v
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-svga
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-vga16
    -rw-r--r-- 1 root root 0 May 11 2001 newxserver.xserver-w32
    -rw-r--r-- 1 root root 17371 Nov 29 2005 rgb.txt
    drwxr-xr-x 4 root root 2048 Apr 10 2006 rstart
    drwxr-xr-x 3 root root 2048 Sep 24 2001 ru
    -rw-r--r-- 1 root root 11088 Jan 2 2007 rxvt.menu
    drwxr-xr-x 2 root root 2048 Jun 5 2001 sawmill
    drwxr-xr-x 2 root root 2048 Jul 25 2005 sysconfig
    drwxr-xr-x 2 root root 2048 Jan 2 2007 twm
    -rw-r--r-- 1 root root 0 Dec 23 2006 xawtvrc
    drwxr-xr-x 3 root root 4096 Aug 29 2006 xdm
    drwxr-xr-x 2 root root 4096 Aug 9 2005 xfce4
    drwxr-xr-x 2 root root 2048 Aug 29 2006 xinit
    drwxr-xr-x 7 root root 2048 Jun 2 2006 xkb
    -rw-r--r-- 1 root root 10734 Mar 18 2008 xorg.conf
    -rw-r--r-- 1 root root 9669 Feb 22 2006 xorg.conf.200602221933
    -rw-r--r-- 1 root root 9196 May 4 2006 xorg.conf.20060504173856
    -rw-r--r-- 1 root root 5333 Dec 21 2006 xorg.conf.in
    drwxr-xr-x 2 root root 2048 Dec 18 2006 xserver
    drwxr-xr-x 2 root root 2048 Apr 10 2006 xsm

    also here is the output of xorg.conf:

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "vbe"

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ImPS/2"
    Option "Emulate3Buttons" "true"

    Section "Device"
    Identifier "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    Driver "nv"
    BusID "PCI:1:0:0"

    Section "Monitor"
    Identifier "Radius-73"
    Option "DPMS"

    Section "Screen"
    Identifier "Default Screen"
    Device "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    Monitor "Radius-73"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"

    Section "DRI"
    Mode 0666

    also when i try to write Startx i got 3 errors :
    X:cannot stat /etc/X11/X (no such file or directory) aborting....
    Xinit : connection refused (errorno 111) unable to connect to X server.
    Xinit : No such process (error 3) server error.
    Thanks very much again for your support:)
    Last edited: Mar 19, 2008
  7. falko

    falko Super Moderator Howtoforge Staff

    Have you tried what Olli suggested?
  8. kadi

    kadi New Member

    Thanks alot for your help

    Hello mr/Falko
    Yes i did and it results in a new xorg.conf, but the xserver still the same
    when i start, what i think is either something missing or some file is not at
    the right place, or some file corrupted, just to be specific :
    like some people says in the forum that the xorg suppose to be in /usr/lib
    instead of /usr/bin.
    I don't know which is which any more, using knoppix i was able to post
    the contents, i just don't understand all it is that i added to the mode
    1024X768 and that scrambled the whole thing, it is just alot of work to
    start fresh after all this work i have done on this server.
    could it be missing symlink ? I download the driver and each time i try
    to install it from the command line it says : cannot find kernel-source
    for your version (2.6.18-6-686) then offer to download it, i said OK
    i got : cannot find your version on the download ! , then i download
    the kernel-source and extract it , and came to a point where it says
    (if you know where is your source you can direct to it) and does not
    give you chance to find it , nothing it just goes out.
    it is a irritating situation that you don't know where to go, and you
    can't get into your server because of very simple thing you i did.
    Thanks alot for your support:)
  9. o.meyer

    o.meyer New Member Moderator

    Hi kadi,

    you can try to revert all the changes you made - you have pasted your working configuration here. That was the configuration on this server, right? But you wrote that it was working after the changes - so are this new problems, or the result of the changes to the available resolutions?

    Best regards,

  10. kadi

    kadi New Member

    Thanks Olli

    Thanks Olli for your reply.
    Yes this was the configuration i made when you suggest it and was ok, i didn't
    change anything, then for no reason startx is gone and when that happened, i did
    dpkg-reconfigure -phigh xserver-xorg.conf
    and it finished the auto config.
    try to startx again after reboot , the same.
    I just don't get it , what is causing that !
    Now i may ask you another thing:
    I run apt-get upgrade hoping that may be correct this problem, and it ran
    at the end gave me error and said "please run apt-get update to correct this problem"
    then i close it that was the only way, and ran apt-get update and that is what
    i got :

    W: There is no public key available for the following key IDs:
    W: GPG error: http://sidux.com sid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3916C431F80994F6
    W: You may want to run apt-get update to correct these problems
    E: Some index files failed to download, they have been ignored, or old ones used instead.

    this was not their before , i ran the apt-get always i never get this message
    it just came after the upgrade stop.

    It is just weird that these things happing for no reason.
    Thanks alot again for your help:)
  11. o.meyer

    o.meyer New Member Moderator

    Hi kadi,

    maybe you should try to use your xorg configuration that you've posted here - you know, the configuration with the resolution problems. If it works, you would have at least a desktop for now - or rather a working xorg.conf that you can use if further configuration changes fail.

    Btw, the gpg error you got is nothing dramatically and does not relate to your xorg configuration. This could happen from time to time.

    Best regards,

  12. kadi

    kadi New Member

    Hi Olli Thanks

    Hi everybody
    Thanks to everybody contribute in helping on this post
    comes to find out that each time i make reconfigure
    to autodetect it put different input devices and
    video model.
    I solved the problem by little agressive step, uninstalling
    xserver* and reinstall it, then reconfigure it.
    Alot of thanks to all of you for your support.
    Last edited: Mar 20, 2008

Share This Page