URGENT :::how to open the uploaded OpenOffice SpreadSheet in Windows

Discussion in 'Programming/Scripts' started by itramesh_p, Jul 28, 2006.

  1. itramesh_p

    itramesh_p New Member

    Hi frnds,
    i uploaded a OpenOffice SpreadSheet (.sxc)in windows platform .now i want to download that file. But when I click that download link of that file .it is not opening ,in the particular correct xls(Spreadsheet) format.
    its opening that file with some mixing of junk values. i saved that file as .sxc format before uploading .

    But if i renamed that file as .xls extension means then i can easilly Upload and downloding also done properly.
    Its opening the file in Correct format .any one can you clarify this doubt Urgently and send me the code (java Script code)

    My Scritp code is:
    <SCRIPT type=\"text/javascript\">

    var tempstr;
    function call_XLfun(S){
    var theSpreadsheet = new ActiveXObject(\"Excel.Application\")");
    var theBook = theSpreadsheet.Workbooks.Open(tempstr)");

    with thanx and especting quick reply,

    Ramesh P
    [email protected]
  2. falko

    falko Super Moderator ISPConfig Developer

    You mean it shows the contents of the file in your browser (with lots of stupid characters) instead of opening and showing the file in OpenOffice? Maybe the easiest solution is to right-click and download the file and then open it in OpenOffice.
  3. itramesh_p

    itramesh_p New Member

    Plz Urgent :: help me to solve this

    Hi frnds,
    i tried ur thoughts but i din't get result .

    plz if u know any othr solution ,let me know
  4. falko

    falko Super Moderator ISPConfig Developer

    You downloaded the file, and then you couldn't open it in OpenOffice? Are you sure it's a valid OpenOffice file?
  5. itramesh_p

    itramesh_p New Member

    it is a Correct OpenOffice file only.When i click that Link of opening that file then it is not opening properly ,its giving some junk values
  6. falko

    falko Super Moderator ISPConfig Developer

    What about my previous proposal?

  7. itramesh_p

    itramesh_p New Member

    it is Solved

    Hi frnds,,
    It is solved ..
    For that mentioned pbms.. Some Configuration in explorer.
    Tools- internet Option --Security -- CustoomLevel .. Make enable to allow New ActiVeX Object Creation ..
    then It is working Fine ..

    ANy way Thnx Frnds,

    Ramesh P

Share This Page