User cron doesn't run

Discussion in 'ISPConfig 3 Priority Support' started by Stelios, Dec 4, 2020.

  1. Stelios

    Stelios Active Member HowtoForge Supporter


    For some reason, the cron doesn't seem to be executed. The command works fine when I run it from the terminal.

    root@myserver:/var/log# cat /etc/cron.d/ispc_web72
    */10    *    *    *    *    web72    export USER=web72 && /var/www/clients/client1/web72/private/phplist -pprocessqueue >>/var/www/clients/client1/web72/private/cron.log 2>>/var/www/clients/client1/web72/private/cron_error.log 
    The /var/www/clients/client1/web72/private/cron_error.log shows nothing as it doesn't get executed at all.

    Last edited: Dec 4, 2020
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    It shows nothing because it captures stderr there, but you already sent stderr to /dev/null. What makes you think it's not running?
  3. Stelios

    Stelios Active Member HowtoForge Supporter

    I had a typo in the cron 0/10 instead of */10....once I removed that and started cron it worked. Sorry for the hassle.
    Jesse Norell likes this.

Share This Page