User FTP access problem

Discussion in 'Installation/Configuration' started by koheleth, Oct 16, 2019.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Exactly. @till explained that in #10 and #7. Except of course it was not ftp user, but shell user.
  2. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Your initial problem was that you were unable to update your wordpress site, which you should still fix. It is only a matter of time until your sites are hacked and your server taken over for malicious use if you do not keep your software (OS, cms, and even ISPConfig) updated.
  3. koheleth

    koheleth Member

    Not update WP ... the install was the latest, it was to delete a theme or add one or a plugin etc, just keeps asking for some access info which I cannot seem to supply. But yes that would apply to any WP updates as well.

    I can install any theme and plugin manually, takes just a few more clicks that's all, no big deal and upgrading WP manually takes just the time to upload the new files. We are getting so lazy today. :cool:

    In Virtualmin you just click a button to change from root to domain owner permissions on files, that is well cool.
    If ISPC3 was written Perl you could easily add it lol.

    It will do me good to be a bit different and upgrade and install software manually.

    I need to lose some weight.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no need to do any update manually, it has been explained to you several times in this thread that the whole reason for your issue is that you uploaded the files as root without changing them to the appropriate user afterward. I have no idea why you still did not chown them so that you can install updates, themes plugins etc. in wordpress. @Taleman showed you in #8 even the detailed commands to do it.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not required in ISPConfig that's why such a function does not exist, users don't even have root access. They use a shell user ot FTP user of a site to upload the files which ensures that they are owned by the right user automatically. When you, as admin, have choose to go a different route and upload them as root, then it is up to you as admin to change the owner to the right users. thats's not ispconfig specific by the way, you have to do this in any unix like operating system when uploading files as root user, no matter if the system uses a control panel or not.

    This is not required on ISPConfig systems. Your current issue is caused by a mistake that you made as root user and you reject to correct it while you were told several times in this thraed to do this and how to do this and that's why wordpress refuses to install updates, plugins and themes.
  6. koheleth

    koheleth Member

    As I said I am very happy, had it too good in the past as usual.

    I have mostly used graphical user interfaces because of their simplicity.

    I have have to say though that for me the add ftp user is just simply not working, maybe because it's a home server and you have yet to look into the nitty gritty of that. Not my problem.

    I do not host people with ISPC3 so not a worry, if I was in a datacenter somewhere I expect all would work fine.

    I think the support here is top notch. Yourself and Taleman being exceptional.

    Home servers will probably be the new big thing soon, because it is free.

    Be quite a market I reckon. Hence my interest.

    Last edited: Oct 17, 2019
  7. koheleth

    koheleth Member

    I did know that did I.
  8. koheleth

    koheleth Member

    It should just work out of the box.

    Nothing wrong in striving for perfection eh!
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    It works out of the box on several hundred thousand servers that run ISPConfig, so the question here is what you did wrong or what you configured wrong outside of ISPConfig like your router.

    It does. Your FTP problem is not related to ISPConfig, it's an issue that your router or firewall blocks ports that are required by passive FTP.

    If you would have chowned it to the right user and if you would have used the PHP mode that is required for CMS systems (PHP-FPM or PHP-FCGI, see manual) and if suexec is on (which it is by default, might just be that you disabled it manually).
  10. koheleth

    koheleth Member

    Not an aswer to the problem though ( I liked his response ) , when I started I said I knew the problem was I installed as root, but the whole thread is about not able to create a ftp user that actually works? In my instance.

  11. koheleth

    koheleth Member

    Till can I just get rid of all firewalls and test?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is not the FTP user, this has been explained to you several times already. Your problem is that a firewall or router outside of the system blocks ports that are required for passive FTP. Read again post #17
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig did not setup any firewalls by default and did not setup your router. Get the manual of your router and configure it correctly to allow the passive port range that you configured in the ftp server.

    And in case you enabled the ispconfig firewall under System > Firewall, then you can deactivate it there as well.
  14. koheleth

    koheleth Member

    Ok, as I said before the router rejects some ports and my ISP offer no help on the fixed IP they give freely and home servers of any sort, not daft eh.
    Thank you for your patience and responses.
  15. koheleth

    koheleth Member

    I did reply to that. Till your a typical engineer :)
  16. koheleth

    koheleth Member

    Donald Trump might even call you nasty :) Just kidding.
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Then use an FTP client where you can force active FTP mode so you don't need passive ports. Or create an ssh user in the website (without chroot jail) and use that to upload by scp/sftp. The reason that your sftp connect failed was that you sued a user that was not for that website, you used a user you created manually outside of ispconfig so its permissions must have been wrong. Or even better, put your system in a datacenter. Cloud nodes are available for starting prices between 3 - 5 eur / month.
  18. koheleth

    koheleth Member

    Nothing wrong doing so though. Surely.
  19. koheleth

    koheleth Member

    Thanks will take it up with winscp.
    The whole point btw of a home server with fiber optic so available these days is to host your own stuff.

    I use dedicateds for business but home servers has a lot of potential future ventures.

    Just need something that works.

    I have yet to find the solution to this ftp error behind a isp router and it's allowed limitations, probably they are just one step ahead.

    Free IP for home servers and not support.
    Like the two Google guys people can be scarey clever.
  20. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    While it's not "wrong" per se, it can certainly be better to not require manual login to update, as you cannot take advantage of automatic updates, which are put out regularly for wordpress core, and even some for plugins when there is a severe enough security issue.
    koheleth likes this.

Share This Page