"User unknown in virtual alias table" when sending emails from external servers to ISPConfig server

Discussion in 'ISPConfig 3 Priority Support' started by omolinete, Oct 28, 2015.

  1. omolinete

    omolinete New Member

    Hi All,

    This is my first message. I bought today a subscription for the next 6 months as I think that this project really worth it, and I would like to support it as much as I can.

    One week ago, I've installed ISPConfig in a new Debian's (Jessie) server following every step explained on the guide "The Perfect Server – Debian 8 Jessie (Apache2, BIND, Dovecot, ISPConfig 3)", located at https://www.howtoforge.com/tutorial/perfect-server-debian-8-jessie-apache-bind-dovecot-ispconfig-3/

    All was installed without any problem nor error, and seems to work flawlessly except one thing related with the incoming mail.

    Unfortunately I am getting the error message "User unknown in virtual alias table" everytime I try to send an email from other mail servers external to the ISPConfig server. I've been testing with differents email providers to be sure that the problem is on the ISPConfig server side.

    On the other hand, ISPConfig sends perfectly any email message to others email accounts located outside him, so the problem is happening only in one direction: from outside to the ISPconfig server.

    So, I downloaded and searched in the ISPConfig Manual about how to solve that behaviour but I haven't found any other step to do when you add a domain and an account for the mail service (apart the ones I've done by myself and that are explained in the documentation with screenshots too).

    Prior to create this thread, I've searched on the ISPConfig's forums too, and I find the explanations a bit confusing.

    Till, Falko, and other experienced users gave help to others like me which had the same problem, but they mentioned some Postfix configuration files which are not cited on the HowToForge's guide, nor in the ISPConfig Manual either.

    I'm talking about a couple of files called "/etc/postfix/virtusertable" and "/etc/postfix/local-host-names", which at least in the release they didn't exist.

    I don't know if I have to create them from scratch, or if it is not necesary to do that anymore, because the data are now stored in a MySQL/MariaDB database, and that kind of configuration/modifications is done now automagically by the web administration panel... I don't know.

    As you can see, I'm a bit lost. I will be very appreciated if somebody could help me with this issue that is hammering my brain since 3 days ago.

    Could somebody help me, please? Thank you very much in advance!!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This files dont exist in a ISPConfig 3 server, they were used on Systems with ISPConfig 2 in the past. The ISPConfig 2 and 3 mail setups are completely different, so advices for ISPConfig 2 can not be applied to your server.

    Regarding the current mail issue: Please post the exact error message that you get in the /var/log/mail.log file when a email arrives.
  3. omolinete

    omolinete New Member

    Hi Till,

    First of all, thank you for your answer.

    Regarding to the output you asked me for in /var/log/mail.log when I try to send an email from an external mail account on another server, here is just where I'm feeling lost: it doesn't print anything! That also applies for the /var/log/mail.err and /var/log/mail.warn files.

    So, after seeing that behaviour and thinking about how fast was the automatic generation and sending of the MAILER-DAEMON bounce email by my current/old control panel (it's a Plesk), where in fact the message "User unknown in virtual alias table" is printed, gave me an IMPORTANT CLUE.

    I've just figured out that maybe the problem isn't really on the ISPConfig side but maybe on the Plesk control panel side that also hosted the same domain name in the past, but that is currently disabled/not operational there.

    I have deleted that domain name in the Plesk control panel, and I tried to send a new email again... and BINGO!

    It seems that even if the same domain name is added on both servers and on the old one is disabled, the Postfix server in the first one still tries to deliver that email to the old domain declared on itself and not to the other domain outside.

    That is just the correct behaviour from Postfix because the email address I was trying to send the emails never existed in the old server but yes in the new (ISPConfig), so the message "User unknown in virtual alias table" is absolutely logical as this mailbox never existed on the old server even if the domain exist in both servers.

    Please, don't pay more attention to this thread because I can say that my issue is solved.

    Thank you very much for your help again! I've learned a new lesson by the hard way :)

    Kind regards from Madrid,

Share This Page