Virtual...Postfix, Courier And MySQL (FC5) quota problem

Discussion in 'HOWTO-Related Questions' started by hnodine, Jul 3, 2007.

  1. hnodine

    hnodine New Member


    I am using the Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5) setup, and just tried to change a virtual mail user's quota by editing the value of quota in the user's table. Unfortunately, that did not seem to work. The number in the db changed, but the quota reported by the mail server did not. I then descended to their maildir, and tried editing their maildirsize file, then restoring the group and owner but still nothing. In fact, the quota size became zero. Any ideas on why this is happening, or what I can do to change user's quotas after their initial account creation?

    P.S.- Amazon gift card for the first person to get this fixed.
    Last edited: Jul 3, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you get any errors when you applied the quota patch to Postfix? Which Fedora version are you using?
  3. hnodine

    hnodine New Member

    Fedora 5, no errors while installing quota patch

    Thank you for your quick reply. I am using FC5 and encountered no errors while installing the quota patch. I have done some more experimentation, however, and if I add a new virtual mail user with a different quota than the other virtual mail users, the new account has the correct (different) quota.

    As I understand the setup outlined in the guide, we are using a maildir style message storage format, so the maildirsize file in each of the virtual user's top level mail folders is what tracks the quota and the space remaining. When new accounts are created, some program (I assume the local postfix delivery agent) checks to see if the account's folders have been created, then sees that they have not and reads the value in the quota field of the users table when creating that user's maildirsize file. After that happenbs, does the quota field come into play anymore? I think the maildirsize file 'manages' the quota from its creation onward. Is that not the case?

    Also, I am using the maildrop maildelivery agent so that I can take advantage of the headers written by spamassassin to move spam into each user's junk folder (a very nice addition if your users are accustomed to using yahoo or some other webmails). When adding new users, maildrop is not able to create the directories like the local delivery agent can. After the directories have been created, I can set the transport to maildrop and it works as usual, but initially I must use the local delivery agent to create the directories by sending the new user a piece of mail. Is there any way to make maildrop create the directories for new users, or is this impossible.

    Sorry for the long post and for the problems!!!

    Also, I have gained a great deal of useful information from your how-tos and forums, do you have an wishlist? I would like to try to repay you in some small way.
  4. falko

    falko Super Moderator ISPConfig Developer

    I think your quota problem has to do with your usage of maildrop somehow, but I'm not sure. What exactly did you do differently than in the tutorial? Because in my tests, quota was working fine.

    No, I don't have an Amazon wishlist, but if you want to support us, you could buy a subscription (see ) - but I don't want to press you. It can be cancelled at anytime, so you don't have to be afraid that it's an ongoing subscription without end. And if there are problems/questions regarding the subscription, you can always PM Till or me, and we'll try to help. :)

Share This Page