VLC player wont work

Discussion in 'Desktop Operation' started by Ezy, Apr 5, 2008.

  1. Ezy

    Ezy New Member

    Hi I am a newbee to Linux. I installed VLC player through yum...now when I click on VLC player from applications menu nothing happens....there is no message in /var/log/messages..... when I run it my from terminal window with su , it runs, but if I run it with my user it generates an error.

    what could be the reason :confused:
  2. topdog

    topdog Active Member

    whats the error it generates ?
  3. Ezy

    Ezy New Member

    Here is the error message:

    00363000-004c6000 r-xp 00000000 fd:00 16810142 /usr/lib/vlc/gui/libwxwidgets_plugin.so
    004c6000-004da000 rwxp 00163000 fd:00 16810142 /usr/lib/vlc/gui/libwxwidgets_plugin.so
    004da000-004de000 rwxp 004da000 00:00 0
    004de000-00575000 r-xp 00000000 fd:00 14735601 /usr/lib/libwx_gtk2u_adv-2.6.so.0.4.0
    00575000-0057e000 rwxp 00096000 fd:00 14735601 /usr/lib/libwx_gtk2u_adv-2.6.so.0.4.0
    0057e000-0057f000 rwxp 0057e000 00:00 0
    0057f000-00591000 r-xp 00000000 fd:00 28706303 /lib/libz.so.1.2.3
    00591000-00592000 rwxp 00011000 fd:00 28706303 /lib/libz.so.1.2.3
    00592000-00596000 r-xp 00000000 fd:00 28706330 /lib/libgthread-2.0.so.0.1400.6
    00596000-00597000 rwxp 00003000 fd:00 28706330 /lib/libgthread-2.0.so.0.1400.6
    00597000-00599000 r-xp 00000000 fd:00 24248368 /usr/lib/libXinerama.so.1.0.0
    00599000-0059a000 rwSegmentation fault

    even with su it runs but after some time it hangs & the error on terminal window is :
    (.:7325): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GtkObject'
    vlc: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
    3614fc6f-8756-2a26-59d7b07c-62606869 is dumped
  4. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer

    Hi Ezy,

    please paste the output of

    ls /etc/yum.repos.d/

    rpm -q vlc
    Best regards,

  5. Ezy

    Ezy New Member

    Hi o.meyer, Here is the output:

    [[email protected] ~]$ ls /etc/yum.repos.d/
    fedora-development.repo fedora-updates-testing.repo livna-testing.repo
    fedora.repo livna-devel.repo
    fedora-updates.repo livna.repo


    [[email protected] ~]$ rpm -q vlc

    I hope you will be able to help me out :(
  6. o.meyer

    o.meyer ISPConfig Developer ISPConfig Developer

    Hi Ezy,

    a try...

    Please install the following package:

    Add your useraccount to the group "pulse-access" and "pulse-rt"

    Please note that you have to log out and in again to take the changes effect - afterwards look what happens when you try to start VLC from the gnome menu. Additionally paste the output of:

    cat /etc/alsa/pulse-default.conf

    yum list installed | grep wx
    Best regards,


    PS: I've the same package installed on my system and it's working without problems.
    Last edited: Apr 9, 2008
  7. Ezy

    Ezy New Member

    alsa-plugins-pulseaudio already installed

    Hi Olli
    I checked, alsa-plugins-pulseaudio is already installed...please see the output of
    [[email protected] ~]$ cat /etc/alsa/pulse-default.conf
    # PulseAudio plugin configuration
    # Let's create a virtual device "pulse" for mixer and PCM
    pcm.pulse {
        type pulse
    ctl.pulse {
        type pulse
    # Let's make it the default!
    pcm.!default {
        type pulse
    ctl.!default {
        type pulse

    [[email protected] ~]$ yum list installed | grep wx
    compat-wxGTK26.i386                      2.6.4-0.8              installed       
    wxGTK.i386                               2.8.4-6.fc8            installed       
    wxGTK-gl.i386                            2.8.4-6.fc8            installed       
    wxPython.i386                            installed    
    please let me know if you want me to do anything else....

    I think that pulse audio is only responsible for audio but my VLC does not even start.....& audio is fine with Real player & other media related softwares...:confused:
  8. HostV

    HostV New Member

    Very bizarre, personally i've neverh ad any problems with VLC Player

Share This Page