vsftpd difficulties

Discussion in 'Installation/Configuration' started by teves, Oct 18, 2006.

  1. teves

    teves Member


    I want to setup a webserver following the 'Perfect Setup howto' for SuSE 10.1 but I wish to use vsftpd instead of proftpd (I don't need anonymous FTP). I set up vsftpd, changed the vsftpd.conf (mainly listen=NO) and configured vsftpd to run as xinetd service. I tested the connection and everything worked fine.
    But after the installation of ISPConfig vsftpd suddenly doesn't work anymore. Whe I tried to restart xinetd it would fail, 'rcxinetd status' would give 'unused'. When I try to reconfigure the xinetd service in yast, I don't get it to work.

    Any hints?

    Thank you,
  2. teves

    teves Member

    Update: vsftpd difficulties

    Hi again,

    it seems I was able to locate at least part of the problem:

    while I installed ISPConfig, vsftpd was running as xinetd service (during the installation I tried a few times to connect ftp and it worked).
    As setup was finished, ftp didn't work again.
    Looking into the /etc/xinetd.d directory I noticed that the vsftpd file was missing. But in /etc I found the file vsftpd_xinetd.backup_10_18_2006__15_26_25. I moved it into /etc/xinetd/vsftpd did a 'rcxinetd restart' and voila: ftp was running again.

    So what I want to know now is: what happened during the installation? Why was the file deleted?

    Thank you,
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The file was deleted because vsftpd must run trough the ISPConfig tcpserver to run properly with ISPConfig. What you did is to enable the old configuration again. This works only as long as you have not more then one anonymous FTP account on your server.

Share This Page