Warnings in ispconfig.log and path for apache problem.

Discussion in 'Installation/Configuration' started by Pelle, Oct 15, 2005.

  1. Pelle

    Pelle New Member

    15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: WARNING: could not /etc/init.d/apache reload &> /dev/null
    15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1856: WARNING: could not groupadd -g 12007 web7_anonftp &> /dev/null
    15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1857: WARNING: could not useradd -d /var/www/web7/ftp -g web7_anonftp -M -s /bin/false -u 12007 web7_anonftp &> /dev/null
    The init.d/apache dosent exist, but ./apache2 does, where can I change the correct path in ISPconfig for the init.d script? Right now I have just copied

    cp /etc/init.d/apache2 /etc/init.d/apache
    But this should not bee the solution? Have looked every where for to find the path, but no success.

    Also, I cant figure out how to solved the warning about "groupadd and useradd"

    no messages in /var/log/syslog or /var/log/messages.
  2. falko

    falko Super Moderator Howtoforge Staff

    Use phpMyAdmin, and have a look at the isp_server table in your ISPConfig database.

    Run the commands
    groupadd -g 12007 web7_anonftp
    useradd -d /var/www/web7/ftp -g web7_anonftp -M -s /bin/false -u 12007 web7_anonftp
    manually on the shell and see if you get errors.
  3. Pelle

    Pelle New Member

    I get the messages:
    groupadd: group web7_anonftp exists
    useradd: user web7_anonftp exists
  4. falko

    falko Super Moderator Howtoforge Staff

    Ok, then ignore the warnings on the log. :)
  5. Pelle

    Pelle New Member

    I have one more problem. I cant login to the mail!

    Have installed the webmail package in ispconfig.

    Made an email for each domain (have 2 domains).

    But none of these mails work.

    when I enter the email and the password it saying:
    You cannot login with the username and password entered.
    Please check your username and password and try again.
    Then I go in and try to change the password for the email, but then it gives the error with groupadd and useradd.

    BUT! I can easyly login to the ftp for the website with these information (user and password)?

    In the files: local-host-names and virtualuserstable they all have the right information in them about my domain and user?!

    Also my /var/log/syslog is saying about pop3:

    Oct 16 02:17:43 houston2 ipop3d[31377]: connect from (
    Oct 16 02:17:43 houston2 ipop3d[31377]: pop3 service init from
    Oct 16 02:19:19 houston2 ipop3d[31626]: Command stream end of file while reading line user=??? host=gmlitconsultis []
    if this helps.
    Last edited: Oct 16, 2005
  6. falko

    falko Super Moderator Howtoforge Staff

    Seems as if something is wrong with your POP3 daemon... :confused:
  7. Pelle

    Pelle New Member

    After 1 hours of probe scanning, I figure out that its because I have used a bad login.
    Used the [email protected] for login, but finaly found out that I was the "ispconfig" username I needed to use, and then I can log in thru Thunderbird, but cant do it thru UebiMiau, then it will give me the messages of bad login?

    Wierd, now that I can log in, I just need to find out how I can recieve the emails... Have sent an email to the adress, can see the file on my server. But I dosent download the file, and the mail.log just saying:

    Oct 16 13:14:42 houston2 ipop3d[8073]: pop3s SSL service init from 80..xxx.xx.xx
    Oct 16 13:14:43 houston2 ipop3d[8073]: Auth user=w7_pelle host=xxxx.dk [80.xxx.xx.xx] nmsgs=0/0
    Oct 16 13:14:43 houston2 ipop3d[8073]: Logout user=w7_pelle host=xxxx.dk [80.xxx.xx.xx] nmsgs=0 ndele=0
    Do not recieve the email thru pop3 or imap. Any Idea where to look for the problem?

    Have used the perfect setup for debian sarge, so the reason I looking for answers on this forum
  8. falko

    falko Super Moderator Howtoforge Staff

    You're using ipop3d which uses the mbox format so make sure you uncheck Maildir under Management -> Server -> Settings -> Email.

Share This Page