Web-FTP: cannot upload packed files

Discussion in 'Installation/Configuration' started by mark.b, Nov 22, 2006.

  1. mark.b

    mark.b New Member

    I have tested ispconfig for two weeks now... very nice features.
    Some questions... but step by step. First of all i think there is a
    bug in Web-FTP. I am not able to upload packed files with extentions
    *.zip, *.rar, *tar.gz etc. All I get is the message "FEHLER 103: Es wurde kein Username oder Passwort angegeben." and a new login prompt.
    Creating directories or upload normal *.html files is no problem.

    I tested this with different conbinations from that list:
    Server: VMWare virtual Appliance / SuSE 10 Perfect Setup
    Clients: IE6 (Win) / Firefox (Linux)

    So long...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for the report. We will check that.
  3. falko

    falko Super Moderator ISPConfig Developer

    Works for me. :confused:
  4. mark.b

    mark.b New Member

    Hello Till,

    thanks for your reply.
    After the last post I worked with normal FTP Clients and had no problems. But today I tested this again with WebFTP.

    Sorry... I was wrong. The problem are NOT packed files. It seems to be the size of the files. I am able to upload files up to 8MB without the error message. So I thought this is a problem with PHP.

    I changed the php.ini:
    memory_limit 64M
    post_max_size 64M
    upload_max_size 64M

    But noting changed... same error message as descriped in the first posting.
    Quota is installed but not active for this website or user.

    Have you any additional tips what to search for ?

    Actual system: fresh SuSE 10 install (Howto) + ISPconfig 2.2.11

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Which php.ini did you edit? You must change the upload_max_size in the file /root/ispconfig/php/php.ini
  6. mark.b

    mark.b New Member

    Yes yes yes...
    that was the "jumping point" ;-)

    With only a litte adjustment. it was the

    So for my understanding the /etc/php5/apache2/php.ini is for
    the websites and the /root/ispconfig/php/php.ini is for ispconfig only ?

    Thanks a lot again
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's correct.
  8. warrior

    warrior New Member

    I olso have some prob whit this I have change every thing so you can upload max 18M but I cant upload rar files whit 5mb size howe can I get this to work ????
  9. falko

    falko Super Moderator ISPConfig Developer

    So you changed the upload_max_size in your php.ini? Did you restart Apache afterwards?
    Any errors in Apache's error log?
  10. warrior

    warrior New Member

    yes I wright in this in the command promt

    service httpd restart

    where can I found that error logg???
  11. warrior

    warrior New Member

    I get this error

    [error] an unknown filter was not added: PHP
  12. edge

    edge Active Member Moderator

Share This Page