Web inteface inaccessible after upgrading to ISPConfig 3.1.1p1

Discussion in 'Installation/Configuration' started by zenny, Nov 22, 2016.

  1. zenny

    zenny Member


    An upgrade to 3.1.1p1 from 3.0.5 brought in the following problems to a working server :( though the sites are working fine:
    1. The ISPConfig web interface does not load with the following error:

    Checked the memory_limit in php.ini under /etc/php5/fpm/php.ini and it was 128M. Also tried with -1 (for unlimited). But didn't work.

    2. Running certbot dies with:

    # cat /var/log/letsencrypt/letsencrypt.log
    2016-11-22 16:17:07,389:DEBUG:certbot.main:Root logging level set at 20
    2016-11-22 16:17:07,389:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
    2016-11-22 16:17:07,389:DEBUG:certbot.main:certbot version: 0.9.3
    2016-11-22 16:17:07,390:DEBUG:certbot.main:Arguments: []
    2016-11-22 16:17:07,390:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#standalone,PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#webroot,PluginEntryPoint#apache,PluginEntryPoint#null)
    2016-11-22 16:17:07,391:DEBUG:certbot.plugins.selection:Requested authenticator webroot and installer None
    2016-11-22 16:17:07,393:DEBUG:certbot.main:Exiting abnormally:
    Traceback (most recent call last):
      File "/root/.local/share/letsencrypt/bin/letsencrypt", line 11, in <module>
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 776, in main
        return config.func(config, plugins)
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/main.py", line 502, in run
        installer, authenticator = plug_sel.choose_configurator_plugins(config, plugins, "run")
      File "/root/.local/share/letsencrypt/local/lib/python2.7/site-packages/certbot/plugins/selection.py", line 170, in choose_configurator_plugins
        raise errors.MissingCommandlineFlag(msg)
    MissingCommandlineFlag: With the webroot plugin, you probably want to use the "certonly" command, eg:
        certbot-auto certonly --webroot
    (Alternatively, add a --installer flag. See https://eff.org/letsencrypt-plugins
    and "--help plugins" for more information.)
    Any inputs appreciated! Thanks!


    # cat htf_report.txt
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.
    ##### ISPCONFIG #####
    ISPConfig version is 3.1.1p1
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.4.45-1~dotdeb+7.1
    ##### PORT CHECK #####
    ##### MAIL SERVER CHECK #####
    [INFO] I found the following web server(s):
        Nginx (PID 6022)
    [INFO] I found the following mail server(s):
        Postfix (PID 3371)
    [INFO] I found the following pop3 server(s):
        Dovecot (PID 2952)
    [INFO] I found the following imap server(s):
        Dovecot (PID 2952)
    [INFO] I found the following ftp server(s):
        PureFTP (PID 3061)
    ##### LISTENING PORTS #####
    (only        ()
    Local        (Address)
    ***.***.***.***:25        (3371/master)
    [localhost]:25        (3371/master)
    [localhost]:953        (1752/named)
    [anywhere]:443        (6022/nginx)
    [anywhere]:993        (2952/dovecot)
    [anywhere]:995        (2952/dovecot)
    [localhost]:10025        (3371/master)
    [localhost]:10027        (3371/master)
    ***.***.***.***:587        (3371/master)
    [localhost]:587        (3371/master)
    [localhost]:11211        (2222/memcached)
    [anywhere]:110        (2952/dovecot)
    [anywhere]:143        (2952/dovecot)
    [anywhere]:111        (1365/rpcbind)
    [anywhere]:8080        (6022/nginx)
    [anywhere]:80        (6022/nginx)
    [anywhere]:8081        (6022/nginx)
    ***.***.***.***:465        (3371/master)
    [localhost]:465        (3371/master)
    [anywhere]:21        (3061/pure-ftpd)
    ***.***.***.***:53        (1752/named)
    ***.***.***.***:53        (1752/named)
    [localhost]:53        (1752/named)
    [anywhere]:22        (3079/sshd)
    *:*:*:*::*:25        (3371/master)
    *:*:*:*::*:953        (1752/named)
    *:*:*:*::*:993        (2952/dovecot)
    *:*:*:*::*:995        (2952/dovecot)
    *:*:*:*::*:3306        (2659/mysqld)
    *:*:*:*::*:587        (3371/master)
    [localhost]10        (2952/dovecot)
    [localhost]43        (2952/dovecot)
    [localhost]11        (1365/rpcbind)
    *:*:*:*::*:80        (6022/nginx)
    *:*:*:*::*:8080        (6022/nginx)
    *:*:*:*::*:8081        (6022/nginx)
    *:*:*:*::*:465        (3371/master)
    *:*:*:*::*:21        (3061/pure-ftpd)
    *:*:*:*::*:53        (1752/named)
    *:*:*:*::*:22        (3079/sshd)
    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination     
    fail2ban-dovecot-pop3imap  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 110,995,143,993
    fail2ban-pureftpd  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 21
    fail2ban-sasl  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 25
    fail2ban-ssh  tcp  --  [anywhere]/0            [anywhere]/0            multiport dports 22
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination     
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination     
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination     
    RETURN     all  --  [anywhere]/0            [anywhere]/0       
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination     
    RETURN     all  --  [anywhere]/0            [anywhere]/0       
    Chain fail2ban-sasl (1 references)
    target     prot opt source               destination     
    RETURN     all  --  [anywhere]/0            [anywhere]/0       
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination     
    RETURN     all  --  [anywhere]/0            [anywhere]/0
    Last edited: Nov 23, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Check the memory limit again in the cgi php.ini file, it is wrong.

    Regarding certbot, dod not run it with this options as it disables certbot in ispconfig and you will not be able to use it anymore. install certbot exactly as described in the ispconfig manual and do not select a domain.
  3. zenny

    zenny Member

    Here is the output of all memory_limit files. I didn't find cgi php.ini (maybe I am using nginx):

    # grep -Rn memory_limit /etc/      
    Binary file /etc/alternatives/php matches
    /etc/php5/cli/php.ini:396:memory_limit = -1
    /etc/php5/fpm/pool.d/ispconfig.conf:23:php_admin_value[memory_limit] = 4096M
    /etc/php5/fpm/pool.d/www.conf:401:;php_admin_value[memory_limit] = 32M
    /etc/php5/fpm/php.ini:396:memory_limit = 256M
    /etc/php5/fpm/php.ini:397:;;memory_limit = -1

    I did exactly like stated:

    # mkdir /opt/certbot
    # cd /opt/certbot
    # wget https://dl.eff.org/certbot-auto
    #chmod a+x ./certbot-auto
    And it does not show up the dialog-based window which one needs to say 'No' for ISPConfig to take over.
    I think the above is the right procedure?
  4. zenny

    zenny Member

    bump! :)
  5. zenny

    zenny Member

    Seems like it could be a bug?!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    That's really unlikely. If you refer to the topic of this thread above, then it is a config problem on your system. If you need help by remote login, then contact Florian from ISPConfig business support: http://www.ispconfig.org/get-support/?type=ispconfig
  7. Frankm1

    Frankm1 New Member

    I'm having this exact issue after the upgrade on ubuntu 16.04.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Empty the browser cache and delete cookies.
  9. Frankm1

    Frankm1 New Member

    Thanks for the tip but that isn't working even in a different browser.

    Here is what I have in the log
    2016/11/28 18:11:49 [error] 15481#0: *25475 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Allowed memory size of 262144 bytes exhausted (tried to allocate 7168 bytes) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 754" while reading response header from upstream, client: *****, server: _, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/ispconfig.sock:", host: "example.com:8080", server: _, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/ispconfig.sock:", host: "example.com:8080"
    Thank you for having a look.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a PHP configuration error on your server. Your current config allows just
    262144 bytes for PHP programs which is not enough to execute a normal PHP script.

    Create a phpinfo() file in /usr/local/ispconfig/interface/web/ folder, open it in a browser and check in it's output in which php.ini file the low memory limit is set and raise it to w.g. 256 megabytes.
  11. zenny

    zenny Member

    256M did exist already in my debian wheezy php.ini as I posted above #3 (https://www.howtoforge.com/communit...ading-to-ispconfig-3-1-1p1.74818/#post-352005). I tried with -1 to test whether that would work, but without a luck.

    However, migrating everything to Debian jessie server as stated in https://www.howtoforge.com/community/threads/solved-cannot-login-to-ispconfig-admin-panel.74861/ went flawless except a small glitch which was resolved by copying the password for 'ispconfig' db user.

    Thanks anyway for such a robust panel
  12. Frankm1

    Frankm1 New Member

    Hi @till, Memory is now set 256M at all I get is a blank page and no more errors in the log. @zenny tip above doesn't help. Something broke in the update regarding the admin section.
  13. molj

    molj New Member

    Hey, I've been banging my head with this the past few days. And none of the answers I found worked for my case. I did a clean install on a RPI with perfect server instructions.

    What I found was (my server runs on RPI3) that the memory size for php in /etc/php5/fpm/pool.d/ispconfig.conf
    php_admin_value[memory_limit] = 4096M

    RPI only has 1GB of memory so by setting an impossible value, php5-fpm used the default value in vhost configuration (256k), that's my newbie conclusion.

    My solution to this wast to set the memory limit to -1 (meaning it uses all the available system memory):
    php_admin_value[memory_limit] = -1
    till likes this.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Thank you for posting your findings. I've added a bugreport for that.

Share This Page