Webalizer Stats - 404

Discussion in 'General' started by sageman, May 18, 2016.

  1. sageman

    sageman New Member

    Hi there,
    I am really going nuts with this seemingly simple task of viewing Webalizer stats. Our webserver is on Wheezy, ISPConfig runs on version - everything works as expected. Stats are being generated, but so far, we have always used PIWIK or Google Analytics. Now a client wants to take a quick peek at collected data, so I added a password in the Statistics tab in ISPConfig - htpasswd worked, but after successfull login I got a 404 - even though all files were there in /stats/ (index, usage and PNG files) .
    Permissions are 644, owned by webuser/group - it seemed something else was prohibiting the index.html
    I have searched the forum, none of the solutions seem to apply / work. There is a Joomla HTACCESS file in root, but turning oit off shows no effect. I even tried turning off mod_security to no avail. In logs there is only a PHP date() warning (after I tried turning on AWStats).

    After uploading a simply test.html file and adding parts from the stats index, I found that the word "webalizer" seems to trigger the 404 -
    simply REMOVING any instance of the word "webalizer" from the stats html files will show all stats! Very strange.

    Any ideas anyone?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Something in a .htaccess file in the web root folder? I had strange issues with viewing the webalizer stats with some wordpress .htaccess files.
  3. sageman

    sageman New Member

    Yes, there is a Joomla 3.5 .htaccess - but the issue persists even after deleting the file :)

Share This Page