webmail & phpmyadmin Alias Directive timeout

Discussion in 'Installation/Configuration' started by psopacua, Mar 21, 2024.

  1. psopacua

    psopacua New Member

    Hi all,

    I just found out that my Alias Directives for /webmail and /phpmyadmin arent working anymore. Yesterday it did work but now it doesnt work anymore. I dove into it and started debugging but i can't find anything how this is happend. I havent changed configurations and i havent added or edited websites (Running ISPConfig 3). The only things i did is "apt update && apt upgrade".

    Apache error log:
    Apache access log:
    APT History log:

    Does anyone have an idea where i need to look of had an similuar issue it stopped working?

    Thanks in advance,

    Kindly regards,

  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  3. psopacua

    psopacua New Member

    Nope, i looked into it and tried the fixes mentioned there (Directory change in apache config, move the phpmyadmin to backup folder and apt reinstall phpmyadmin, all options give the same output in the logs).

    Well this is the most strangest thing i ever had. Suddenly it started working again after multiple apache2 & php 8.2-fpm restarts its all working again.

    Thanks anyway for take a look @Th0m !
    Last edited: Mar 21, 2024
    Th0m likes this.
  4. lukafred

    lukafred New Member

    It seems that the upgrade process may have affected the functionality of your Alias Directives for /webmail and /phpmyadmin. Here are some steps to address the issue:

    1. Check Apache Configuration: Review the Apache configuration files to ensure the Alias Directives for /webmail and /phpmyadmin are correctly configured.

    2. Verify File Permissions: Ensure the files and directories associated with /webmail and /phpmyadmin have the correct permissions set.

    3. Confirm Alias Paths: Double-check the paths specified in the Alias Directives to ensure they point to the correct directories where webmail and phpMyAdmin are installed.

    4. Restart Apache: After making any changes to the Apache configuration files or file permissions, restart the Apache service to apply the changes.

    5. Review Apache Logs: Monitor the Apache error log for any new error messages or warnings that might provide clues about the issue.

    6. Rollback Changes: If necessary, consider rolling back the changes made during the upgrade using the appropriate package management commands.
    If the problem persists, seeking assistance from the ISPConfig community forums or other relevant resources might provide further insight into resolving the issue.
    ahrasis and psopacua like this.
  5. psopacua

    psopacua New Member

    Well the problem solved itself after a few reboots from what i remember. Strange stuff!
    But thank you for sharing this debugging proces!
    ahrasis likes this.

Share This Page