Website harddisk show quota NAN

Discussion in 'Installation/Configuration' started by andresgt2000, Jan 18, 2020.

  1. andresgt2000

    andresgt2000 Member

    Hi everyone

    My Infraestructure have 4 servers, and it have the last version of ISPConfig (3.1.15p), and the issue is about the quota of websites that show NAN in the monitor ot the "sites" tab.

    All the website have seting the Harddisk Quota in customers and in the web site config.

    I supose that is necesary reconfigure the quota of the hard disk and reconfigure the web server to solve the issue, but I prefere ask firts, because I don't find any post about that. And maybe some have or had the same problem.

    Web Server Apache 2.4

    Thank you for your guide and help.

    Screenshot_2020-01-07 ISPConfig.png

    Attached Files:

  2. andresgt2000

    andresgt2000 Member

    I finded a similar case, excuse me, I suppose is the same. I am go to review and inform to every one.

    Harddisk Quota

    Thak you Till.
  3. andresgt2000

    andresgt2000 Member

    Apparently quota is configured but not working maybe is because I don't set the correct quota in the correct partition (vg0-lv-www), I going to check fstab file and the documentation.

    *** Report for group quotas on device /dev/mapper/vg0-lv--root
    Block grace time: 7days; Inode grace time: 7days
    Block limits File limits
    Group used soft hard grace used soft hard grace
    root -- 899764 0 0 18680 0 0
    daemon -- 4 0 0 1 0 0
    adm -- 4 0 0 1 0 0
    mail -- 16 0 0 4 0 0
    www-data -- 8 0 0 2 0 0
    shadow -- 88 0 0 6 0 0
    landscape -- 4 0 0 1 0 0
    ssl-cert -- 8 0 0 2 0 0

    Total blocks: 7
    Data blocks: 1
    Entries: 8
    Used average: 8.000000
  4. andresgt2000

    andresgt2000 Member

    Yes my old web server work with quota config int the partition vg0-lv--www. This must be my error.
  5. andresgt2000

    andresgt2000 Member


    Steps to Enable Quota in the correct partition:

    1. Execute the this command "quotaoff -a", to disable the quota of all partition.
    2. Backup fstab partition.
    3. Edit fstab and add this line ",usrjquota=quota.user,,jqfmt=vfsv0" in the correct partition.
    4. Remove the line ",usrjquota=quota.user,,jqfmt=vfsv0" from / and add this ",noquota". *
    5. Remount the partition that need the quota configuration with this command "mount -o remount /var/www"
    6. Remount the partition that don't need the quota configuration with this command "mount -o remount /" (This not work, I think because is the root partition, I believe is needed to restart the server. I will going to try this in a convenient moment)
    7. Delete file and quota.user from / **
    8. Restar the server (This step I can not execute in the momment of reconfigure the quota, beac)
    9. Execute the verifiaction check of partitions "quotacheck -avugm".
    10. Enable Quota of partition "quotaon -avug". (In this case maybe I must to force enable just the specific partition and add -R for not read root partition)
    After execute this steps the NAN message in disappear and show the correct data, the only thing is the soft limit and hard limit appear as unlimited, but the website have a correct quota assigned.

    To solve this I tested change the quota with a 1MB plus, and after a few minutes the values of soft limit and hard limit appear.

    *With regard to point 4, perhaps, if someone can clarify to me if it is okay what I am thinking about removing the quota configuration from the root partition is correct or if you should do some other step.

    In the documentation (quota -h) there no exist a parameter to delete the configuration directly.
    Th0m likes this.

Share This Page