Website of Created User not working and Webmail Login Problem

Discussion in 'Installation/Configuration' started by techman83, Feb 27, 2006.

  1. techman83

    techman83 New Member


    I've managed to find answers to most of my questions so far, apart from these two.

    Problem 1.

    After creating a client and the relevant dns entries, internally the website gets pointed to the "It Works!" page rather then the actual website i've uploaded. Externally some get that page and others get an access forbidden page and another computer got the shared IP error page.

    This is what the dig results posted
    ; <<>> DiG 9.3.1 <<>>
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37670
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ; IN A

    ;; ANSWER SECTION: 86400 IN A


    ;; Query time: 13 msec
    ;; SERVER:
    ;; WHEN: Mon Feb 27 13:41:51 2006
    ;; MSG SIZE rcvd: 72

    I have created a user with administrator flagged and uploaded via ftp using that administrator.

    Problem 2.

    When i try to login to webmail with that user to the email using the email adress ([email protected]) it says:

    Invalid Login

    Password incorrect! Please go back and try again.

    that is when i access it from:

    but i can log in fine from the server's private address. I am also able to send mail with it, but as yet nothing has been received. Although haven't gotten any bounced messages.

    I have flagged mail directory. And i checked:

    tail: cannot open `/var/log/' for reading: No such file or directory
    ==> / <==
    tail: error reading `/': Is a directory
    tail: /: cannot follow end of this type of file; giving up on this name
    tail: cannot open `warn' for reading: No such file or directory
    tail: no files remaining

    I have poured through the forums for answers and tried everything i could think of! So any help would be much appreciated.
    Last edited: Feb 27, 2006
  2. falko

    falko Super Moderator Howtoforge Staff

    I get "Access forbidden!". What directory did you upload to? Did you follow this tutorial?

    The mail log is /var/log/mail/info in Mandriva.
    Please post the output of
    netstat -tap
  3. techman83

    techman83 New Member

    Yep, followed that setup to a T... well I'm pretty sure I did, not impossible that I missed something.

    I have uploaded via ftp using the admin account i created for the site. I placed the site into the "web" folder. Internally I get a page that says "It Works!" in bold letters, although other machines on the network get the shared IP page or the forbidden page (tryed refresh and clearing out cache). It seems externally the same variety occurs!

    One thing I have noticed, when I log in via ftp, under the owner colum there is a question mark on everything bar the "Maildir" which is root.

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:1025 *:* LISTEN -
    tcp 0 0 *:nfs *:* LISTEN -
    tcp 0 0 *:imaps *:* LISTEN 2820/xinetd
    tcp 0 0 *:pop3s *:* LISTEN 2820/xinetd
    tcp 0 0 *:967 *:* LISTEN 2908/rpc.mountd
    tcp 0 0 webbox.crac-transport:10026 *:* LISTEN 15074/master
    tcp 0 0 *:mysql *:* LISTEN 2185/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 3131/smbd
    tcp 0 0 *:pop3 *:* LISTEN 2820/xinetd
    tcp 0 0 *:imap *:* LISTEN 2820/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 2256/portmap
    tcp 0 0 *:http *:* LISTEN 29532/httpd
    tcp 0 0 *:81 *:* LISTEN 29236/ispconfig_htt
    tcp 0 0 *:817 *:* LISTEN 2331/rpc.statd
    tcp 0 0 *:ftp *:* LISTEN 15008/proftpd: (acc
    tcp 0 0 *:* LISTEN 8521/named
    tcp 0 0 webbox.crac-transpor:domain *:* LISTEN 8521/named
    tcp 0 0 *:918 *:* LISTEN 2858/rpc.rquotad
    tcp 0 0 webbox.crac-transport.:5335 *:* LISTEN 2649/mDNSResponder
    tcp 0 0 *:smtp *:* LISTEN 15074/master
    tcp 0 0 *:https *:* LISTEN 29532/httpd
    tcp 0 0 *:7741 *:* LISTEN 3334/lisa
    tcp 0 0 *:microsoft-ds *:* LISTEN 3131/smbd
    tcp 0 0 *:ssh *:* LISTEN 2760/sshd
    tcp 0 480 ::ffff: ::ffff: ESTABLISHED 4105/0
  4. falko

    falko Super Moderator Howtoforge Staff

    You're using a POP3/IMAP daemon that uses the mbox format. Please make sure that you did not enable Maildir under Management -> Server -> Settings -> Email in ISPConfig.
  5. techman83

    techman83 New Member

    Yep had ticked the maildir flag! Mail seems to be working internally between accounts. Still don't seem to be receiving mail externally.

    Thats a step forward I guess :)

    As for the website it still puzzles me, internally its still doesn't seem to provide the right page! And each computer brings up a different error (shared accomodation, a few systems here and various notebooks) whether it be the shared IP page, "It Works!" Page or Access forbidden!

    Thanks for your response!
  6. techman83

    techman83 New Member

    Well I think I have most of it figured out!

    Problem 1

    DNS Related, I can now get it to work internally! I think the is only a redirecting mob, so I will have to wait till I can afford to register a proper domain till i can get anything working externally. Which I planned to do anyway.

    Problem 2

    Same! Plus I had the maildir flagged :eek:

    Thanks for your help

Share This Page