Weird and worrying Open Graph results in Facebook debugger

Discussion in 'Server Operation' started by tfboy, Apr 29, 2017.

  1. tfboy

    tfboy Member

    I've had a website, running for a couple of months, all was OK after I sorted out a Let's Encrypt SSL issue. I have the site running fine under SSL and everylooked OK until I recently discovered an OG issue with facebook where when someone posted the link (non-secure version) it would come up with a bad text link saying files may be moved or deleted. To be honest, I didn't know anything about Open Graph until then so have since been learning how to optimise things and try and resolve the issue. I realised if I used the SSL in FB, it worked better (providing the https:// prefix).
    Fast forward a couple of weeks and I just set up a new site for someone else on the same server via ISPConfig;
    That site is up and running and OK as far as I can tell.
    However, my big worry is that if I then use the Facebook debugger thing and type in the domain, it says there's an HTTP 301 redirect to :eek:
    How is this happening?
  2. tfboy

    tfboy Member

    OK, panic over.
    Turns out I had declared the IPv6 address for the videliomedia domain and not the xavelec one so I guess the FB debug tool resolved using IPv6 and pointed somehow to the videliomedia domain.
    I've now added the IPv6 address to the xavelec domain and the problem appears to be solved. Phew! :)

Share This Page