Weird behaviour in a particular site

Discussion in 'Server Operation' started by Fernando Azevedo, Nov 26, 2020.

  1. Fernando Azevedo

    Fernando Azevedo New Member

    Hi All,

    I am facing a weird behaviour in one particular site. The context is my Client has an EC2 instance on AWS that is acting as a web server for his site only. He is migrating that site to my installation and it was supposed to be a simple thing. Everything was set up and no issues found neither in dumping (and populating) the database nor in copying the files to the proper (web) local folder.

    The Site was only available on HTTP and one of the goals was to have it changed to HTTPS so one of the things done was getting a LE Certificate and have and HTTP --> HTTPS redirect. So far, so good...

    Now the fun begins... when the DNS records were changed to point to the ISPConfig web server the site looks all weird. It's as if CSS was not being loaded but not only there are no errors on the ISPConfig Log files, I also loaded the CSS directly and everything was there. Cleared caches and the problem persisted in any web browser I tried... :-(

    Next suspect was web server rewrites... Since I use Apache in ISPConfig and the Client had/has Nginx on AWS, in order to speed up his change I tried setting up a dedicated Nginx web server for him on a separate server and reverse-proxy to it from ISPConfig... same result! :( But when I browse to this separate server, which is as exact replica from the one at AWS, the page looks good! (apart from the Portuguese special characters that are not showing correctly, but that I think would be a minor issue in having the correct charset configured... I think!!!)

    Any hints on what might be happening?

    I appreciate in advance any help that you guys can provide.

  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Maybe incorrect file permissions or different PHP version that's incompatible?

    Did you enable Let's Encrypt AFTER changing the DNS records? Otherwise, it might be that there is no valid SSL cert. You might try re-enabling LE.
  3. Fernando Azevedo

    Fernando Azevedo New Member

    I enabled LE when I created the site before changing the DNS records. I accessed the first time without any contents and the default index.html file was served correctly over HTTPS.

    Did I do something wrong?
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Yes. If the change is propagated now, re-enable Let's Encrypt to issue a certificate.

Share This Page