Wired problem creating a new user

Discussion in 'General' started by Spaetzle, Oct 9, 2008.

  1. Spaetzle

    Spaetzle Member HowtoForge Supporter


    Yesterday a customer of mine created a new user. Everything went well. But when the customer tried to change some settings he was not allowed (Error: "Sie haben nicht die notwendigen Rechte um diesen Eintrag einzusehen oder zu bearbeiten" ->English some thing like: "You have not the neede rights for seeing or editing this entry").
    The user wasn't usable either. No email could be sent to him (User unknown in local recipient table), nor was he able to connect to webmail.
    But: The user was created in the filesystem on the server but with a wrong group id and in the wrong directory. He had the group id of another customers web. The home directory was created in this (wrong) customers users directory too.
    I and my customer were not able to reproduce this behaviour.
    All users created on any web there after worked as wanted.
    Anybody observed something like this bevor? Does anybody have an idea what maybe went wrong?

    Best regards

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks like the user had a corrupted entry in the isp_dep table and which resulted in the assignment to the wrong website. I have seen this problem here in the forum but was not bale to reproduce it yet, maybe some kind of race condition that causes this.

Share This Page