Wordpress Auto Update/Plugin Installation Problem

Discussion in 'General' started by HyperAtom, Aug 4, 2010.

  1. HyperAtom

    HyperAtom New Member

    Hi all, everytime I try to autoupdate wordpress, the updater is unable to write to the configuration files. All the permissions are as they should be.

    When updating or installing plugins, I get

    Could not create directory. /web

    Folder permissions are 775 on /web /plugins /upgrade /upload

    Trawling through the forums, I did see something about the php setting in the control pannel having an effect on wordpress auto update http://www.howtoforge.com/forums/showthread.php?p=232821

    I am using Fast-CGI with SuExec enabled
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the files are not owned by the correct User. Chown all files and folders inside the web directory recursively to the web user and client group of this website. I run several wordpress installs on ISPConfig 3 with suexec and fast-cgi and the auto update works fine with ispconfigs default settings.
  3. HyperAtom

    HyperAtom New Member

    Hmm strange, ive checked all the directories and theyre all owned by web1 and ground client0 which is fine. Guess i'll have to look into it.
  4. yoplait

    yoplait Member

    Same problem on my side, and the rights seems to be good...
    Maybe wordpress is running with the www-data:www-data user, or something like that ?
    I can see files created by wordpress with theses rights... HyperAtom, do you have the same ?
  5. HyperAtom

    HyperAtom New Member

    Since my server was only a test system, I reinstalled to 3.0.3 beta and updating hasn't failed in wordpress since.
  6. GenNS

    GenNS New Member

    I'm also having troubles.

    I followed the Perfect Server guide for Ubuntu, just to set up a WordPress hosting server in a LAMP environment.

    I found ISPConfig3 pretty easy to use in terms of setting up new clients and sites, and it was pretty smooth sailing as far as getting WordPress installed.

    However, I can't auto-update WordPress or plugins, and I get other strange error messages.

    For instance, on the first blog I set up, when I go to the Dashboard, in several places I see this error message:

    Also, if I go to the Permalinks page in Settings, at the bottom, I get this message:

    (with the textarea after it)

    Trouble is, since my only experience with Linux etc. is having followed the Perfect Server guide to get this set up, I'm not even sure where that file is.

    I found a post someplace about making sure to CHOWN the web directory to the ISPConfig3 user via a command like this:

    ...which I've done for the three clients I've set up so far. But on this one particular client (my own blog), I still get those error messages I've listed above and cannot auto-update anything.

    I've also checked numerous WordPress blogs, forums and posts and haven't found anything useful in terms of a solution.

    Is there maybe some step I've missed in ISPConfig3? Or can somebody offer any help or suggestions here?

    Thanks much in advance,

  7. GenNS

    GenNS New Member

    Actually I've tried the auto-update on the other two blogs and they all fail.

    And I tried updating the Akismet anti-spam plugin and it failed as well, giving me this error:

    After I attempt either type of update (WP autoupdate or plugin update) the admin and blog are unavailable, just giving me this message:

  8. renders

    renders New Member

    Should the files be owned by client0 or client1? If you don't select the client, it defaults to client0..

  9. GenNS

    GenNS New Member

    Are you referring to the example CHOWN I pasted in my original post?

    In ISPConfig3, Web1 goes with Client1 and so on.

    Or maybe I'm misunderstanding what you're asking.
  10. renders

    renders New Member

    I noticed on my install that if I am logged in as the control panel admin, I can assign the web site to a particular client. If I don't select the client, it defaults to client0.. I have only one client setup on my system and only client1 exists in the drop down.

    I am wondering if defaulting to client0 breaks the permissions..

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The problems you describe happen if the wrong php mode is selected in the website settings. Make sure that you selected the correct php method for the website, use e.g. php-fcgi and enablke suexec checkbox.

Share This Page