Wordpress on ISPConfig3 not working

Discussion in 'Installation/Configuration' started by rkstengel, Oct 30, 2016.

  1. rkstengel

    rkstengel New Member

    I am trying to install Wordpress in the root directory however, when I try to open the initial page it is blank. Nothing happens.
    I have tried settings permissions to 777 and owner to web4:client2 but nothing works. It works fine if I install to .../web4/wordpress/
    Any thoughts?
  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Install wordpress in web4/web as this is the root-folder for the website.
    rkstengel likes this.
  3. rkstengel

    rkstengel New Member

    You are correct my bad. I am installing in web4/web. I have tried installing in web/wordpress and then moving, also installing direct in /web but nothing works. It would be easier if there was a simple way to change what is currently /wordpress to a hidden folder so it appears the folder is not present. . Thanks for replying btw...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Installing wordpress is really easy:

    cd /var/www/yourdomain.tld/web
    wget https://wordpress.org/latest.zip
    unzip latest.zip
    mv wordpress/* .
    chown -R web4:client1 *
    rmdir wordpress

    Replace group client1 with the client group of this website, you can see the user and group of the website on the options tab of the site. Then open your domain in the browser and follow the instructions of the installer.

    And do not do a chmod 777. This is insecure and not nescessary and it can cause your website to fail.
    rkstengel likes this.
  5. rkstengel

    rkstengel New Member

    Crazy that your instructions are so simple and worked GREAT!!! Thanks...
  6. rkstengel

    rkstengel New Member

    Thanks for replies!

Share This Page