www can't show

Discussion in 'Installation/Configuration' started by veuster, Aug 12, 2010.

  1. veuster

    veuster New Member

    My web suddenly can't be accessed with www.domain.tld or domain.tld

    I didn't do anything.

    I used it as webserver and nameserver.

    It can be accessed only with IP address, ns1.domain.tld or by ssh

    The DNS setting is fine because I don't change it and everything works fine before.
    I have experience with this condition and solve it by changing named.conf.
    Listen-on and allow-query parameter to { any; };

    But now, the named.conf is fine but I have the same problem. It's almost 3 weeks that the server is running fine and now suddenly this happens.

    What should I do?
    Last edited: Aug 12, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you ping www.domain.tld, do you get the IP address that is selected in the website settings?
  3. veuster

    veuster New Member

    don't know why

    No, it points to the parking page of my domain provider.

    Today, my site can be accessed again with www.domain.tld

    Yesterday I only change the DNS host in my domain provider setting.
    I remove the domain provider name server from the DNS host and keeps only my nameserver.

    Is the domain provider name server the cause of this?

    My domain provider, allows the client to have many DNS host, one as primary and many text field for secondary.
    So, I think that I want to use the parking page as the emergency page if anything happens to my server.
    I put my name server as primary and secondary with the host ns1 and ns2. Then for the other secondary I used the original name server that was provided by domain provider.

    I want to know if the case that happens yesterday is normal thing that happens every once and a while or not.
    I mean, is it possible that there's a broken link somewhere in the world wide web that makes my website can't be reached?
    But I can accessed my control panel with IP and also by SSH.

    If this normal then I will return the tertiary and fourth DNS Host to point to the parking page again.

    But if that's the cause, then I would have to rely only on my server, because I don't have backup server for now.

    Or maybe there's other answer to this?
  4. falko

    falko Super Moderator ISPConfig Developer

    That's the problem. I'd remove the nameservers of your registrar and only use your own ones.
  5. veuster

    veuster New Member


    Why can't I use the registrar nameserver?

    I just need it for emergency, just in case my server down or anything.

    Doesn't it make sense in logic?

    If I'm not mistaken, one of the tutorial here also use one own nameserver as primary and the registrar nameserver as secondary.
    Am I right?

    So, it just can't be used? That's the end of it?
  6. pawan

    pawan Member

    Primary NS1.mydomain.tld and NS2.registrar-domain.tld

    I am also using it like mentioned in the subject.

    is there anything wrong with it.

    In addition to using NS1.mydomain.tld, I have changed A records for all domains hosted on my server in the registrar record to point to myserver ip.

    is there anything wrong with it.
  7. falko

    falko Super Moderator ISPConfig Developer

    It seems as if your registrar's nameservers hold different records for your zone than your own nameservers, i.e., your registrar's nameservers are not configured as a slave of your own nameservers. If they were, you could use them, of course.
  8. bahar2509

    bahar2509 New Member

    I couldn't access my dns from LAN while I can access by IP address

    I just installed ISPconfig 3 in Ubuntu 10.4 as guided in ISPconfig3 Tutorial. During the installation, everything is run well. But when trying to access in Local Area network, my DNS e.g.: http://server1.mydomain.sch.id it was refused, the page cant be displayed. However, when i tried it was running well.

    I also got replied when tried ping
    but ping to myDNS was RTO (request time out)

    Could you please solve my problem?.
    Last edited: Aug 17, 2010
  9. veuster

    veuster New Member


    For Falko :
    Thanks, I think maybe you are right.
    My registrar doesn't give me Total DNS Control, so I can't change zone records of my domain.
    They only give the means to register my server IP address, so I can use it as nameserver for my domain.

    For Pawan :
    From what you're writing, it seems that you have Total DNS control for your domain. Because you can change zone records. So, this thread is not your concern.
    As long as your website can be accessed, there is nothing wrong with the setting. Except if you have the same problem with me.

    For bahar2509 :
    What are you trying to do?
    If you want to access ISPConfig control panel, you have did it right. The control panel must be accessed with IP address on port 8080 (except if you change the port).
    If you want to access your web site on LAN, I think you must set your router or gateway to forward request on DNS port or something.
    I'm not familiar with this, so maybe someone else here can help you.

Share This Page