x2go on Ubuntu tutorial - not connecting

Discussion in 'HOWTO-Related Questions' started by WillStewart, Oct 6, 2014.

  1. WillStewart

    WillStewart New Member

    I found the tutorial on setting up x2go on Ubuntu to be very detailed and well-laid out, with substantive screenshots and a thorough process.


    However, when trying to connect from one Ubuntu Studio 14.04 to another (xfce4 desktops), the client attempting to connect simply timed out.

    The server task manager shows the x2gocleansessions process running all the time. When the client access is attempted, an x2go sqlitewrapper starts up. An x2gosession then starts up, but then disappears. an x2go sqlitewrapper starts up again, then disappears, and the client then times out.

    I don't see anything in the var/log/auth.log at that time.

    Are there some other prerequisites that must be accomplished before this, such as SSH client and server configuring?
    Last edited: Oct 6, 2014
    Tina likes this.
  2. WillStewart

    WillStewart New Member

    Ok, now that I have the right port defined for the firewall (22), I've gotten further along. Now the client immediately gives the following message;

    Access Denied: Authentication that can continue: public key, password

    So then I set up an RSA key, and made it part of the profile.

    Now when i try to connect, it asks for the passphrase, then I shortly get;

    Access Denied: Authentication that can continue: public key, password
    Access Denied: Authentication that can continue: public key, password

    Am I getting closer?
    Last edited: Oct 7, 2014
  3. srijan

    srijan New Member HowtoForge Supporter

    Yes, it is the error for ssh public key, just remove the entry for the X2GoServer IP from ~/.ssh/known_hosts and then connect again it will work.

    See It works on SSH port so you need to remove the keymismatch.

    Better you can just try
    it will give you the same error and from there you can get the exact known_hosts error.

    Paste the ssh output of the server for further assistance.
  4. WillStewart

    WillStewart New Member

    Indeed it was a key mismatch, I reset my RSA key, moved the pub over to the server, and everything is working now.

    Thanks much!
    Ahmed_Al-Jumaili likes this.
  5. Ahmed_Al-Jumaili

    Ahmed_Al-Jumaili New Member

    Dear WillStewart,
    I am facing the same problem that you had experienced with x2go. I have the same error, since I have no experience I couldn't solve the problem as you did. Could you please explain to me how you did it with more details.

    kindest regards,


Share This Page