Xen acpi problem

Discussion in 'HOWTO-Related Questions' started by Guido64, Jan 30, 2006.

  1. Guido64

    Guido64 Member

    I'm reading (and setup a test system) with the "The Perfect Xen Setup For Debian And Ubuntu" howto.

    I have a AMD Athlon 1GHZ system for this with 384MB Ram.
    I needed to enter acpi=force into menu.lst of the host system or else the
    system wouldn't poweroff properly.

    Now i installed Xen from source the way Falco explained and have again this poweroff problem, the system wont poweroff totally.
    I tried acpi=force with Xen but no succes.

    I can't find any error messages in /var/log the system just doesnt poweroff properly. Debian closes and the hd's stop spinning then the screen says OS stopped or something nothing else.

    Does anybody know how and if this can be solved with Xen?
  2. falko

    falko Super Moderator Howtoforge Staff

    You said you compiled the Xen kernels from the sources. Did you enable the correct ACPI settings in the kernel configuration? Can you post the ACPI related lines of the kernel configuration file (in /boot)?
  3. Guido64

    Guido64 Member

    hmm good point

    Hmm no i did not think of that (shame).
    Will do that this week and let you know if that worked out.
  4. itobin

    itobin New Member


    did you get this sorted? im having the same issue,

    i have acpi compliled into the kernel and here is my acpi config

    ACPI (Advanced Configuration and Power Interface) Support
    # CONFIG_ACPI_CUSTOM_DSDT is not set
    # CONFIG_ACPI_DEBUG is not set
    # CONFIG_X86_PM_TIMER is not set
    # CONFIG_ACPI_CONTAINER is not set


  5. falko

    falko Super Moderator Howtoforge Staff

    Did you install all ACPI related packages of your distribution (e.g. acpid on Debian)?
  6. Guido64

    Guido64 Member

    No, i'm sorry didn't have the time yet to look into it.
    Have a lot of work right now. When i did figured it out i wil post it here.
  7. itobin

    itobin New Member


    it works fine when running under the default Debian kernel.

    When i installed Xen i also selected ACPI to compile into the new kernel

  8. Guido64

    Guido64 Member

    How to add acpi into kernel?

    Tonight i tried to figure out how to add acpi to the xen kernel for the host system. I never compiled a kernel. How do i add acpi to the xen kernel?
  9. falko

    falko Super Moderator Howtoforge Staff

    When you ru
    make menuconfig
    you can add it to the kernel. I'm not quite sure in which submenu you find the ACPI options, so you must search a little bit. ;)
  10. Guido64

    Guido64 Member

    I wrote before, i compiled the xen kernel from source, and i did, but it didn't feel like i did it myself, i was following your (falko) instructions.

    When i need to change something what is not in the howto, like this acpi, then i'm lost hahah
    I tried to solve it, searched on google and google groups and everything read a lot of posts.

    I did surfed thru the menuconfig sub menu's so i was kind of warm :)
    I used the search option / in the menuconfig.

    It did found 2 acpi entries about pnp. I thought that where not the right acpi options. so i didn't select those. I wasn't sure menuconfig is used to add kernel options, now i do :)

    After a good night of sleep i started again with "Make menuconfig" and there it is right in front of my nose duh. If i did it right it should now being added to the kernel.

    wel its not added to the kernel so i'm stil doing something wrong.
    i'm going to install the whole host system again maybe that'l help.

    I did a clean sarge install on the host system.
    I'm now at the point to configure "make menuconfig" again and again the acpi options are gone so i think its not possible to add acpi modules into xen kernel.

    I'm lost
    Last edited: Feb 12, 2006
  11. falko

    falko Super Moderator Howtoforge Staff

    If you compiled them as modules (marked with M in
    make menuconfig
    ) then you must put these modules in /etc/modules so they get loaded when the system boots.
    If you compiled them into the kernel statically (marked with *) then it should work right from the start.

    It is possible. I think the problem is you compiled them as modules and did not put them into /etc/modules.
  12. Guido64

    Guido64 Member

    The day before yesterday i installed Sarge several times new over and over again because i want a clean system. Everytime i started the Xen howto and every time there was no "ACPI (Advanced Configuration and Power Interface)" in menuconfig. then i went to bed frustrated it didn't work.

    When i woke up yesterday and started with the system i left the day befor all of a sudden this "ACPI (Advanced Configuration and Power Interface)" was right in the first screen in menuconfig. I thought great, and put a * on "ACPI (Advanced Configuration and Power Interface)" and thought that was oke i started the system but no acpi, no /proc/acpi. So i started al over again with a new clean sarge install on the host system but now there is no "ACPI (Advanced Configuration and Power Interface)" option in menuconfig.

    Your right, i didn't write anything in /etc/modules except this "3c95x" for the nic. I didn't know i had to put something in /etc/modules.
    But when there is no "ACPI (Advanced Configuration and Power Interface)" option in menuconfig i can't give it a * or a M.

    I don't understand one time this option is in menuconfig and a other time it is not.
    Last edited: Feb 12, 2006
  13. Guido64

    Guido64 Member

    I start with setting up Sarge the way falko explains at the beginning of the howto. Except i made /vserver on hdb1. When i reach the line "make menuconfig" in the howto, the acpi options are not present in the interface that shows up. When i reboot the host system at this point and try another time "make menuconfig" the acpi options are present.

    I set the acpi options the way explained in this thread.
    Then i go on with the howto, till the "cp boot/* /boot" line. When i enter the command (cp boot/* /boot) i get: Onbekend bestand of map (in english: unknown file or map). So it did not install the kernel into the ~/xen/install.

    It probably has to do with my reboot right before i configure "make menuconfig".

    Please can anybody help me with this?
    Last edited: Feb 26, 2006
  14. falko

    falko Super Moderator Howtoforge Staff

    Your reboot causes the variables you set before to be lost:

    ARCH=xen; INSTALL_PATH=../install; INSTALL_MOD_PATH=../install
    After the reboot you should set the variables again and then run
    make menuconfig
  15. Guido64

    Guido64 Member

    With those variables set i get this kernel configuration interface again without the acpi power options. I used the search option, no results either.
    Last edited: Feb 27, 2006
  16. Guido64

    Guido64 Member

    Am i doing something wrong or could it be that for some reason these acpi options might not work with my computer? Wel i don't think its the computer because with the standard kernel it did work. So i have to do something wrong, if Xen supports acpi wich it does. Am i asking the wrong questions? Do i forget something? Or some other reason why this isn't working?
  17. falko

    falko Super Moderator Howtoforge Staff

    I'd really like to help you, but when I wrote the Xen tutorial I didn't focus on ACPI, so I cannot tell if/how this works...
  18. Guido64

    Guido64 Member

    Oke i understand. Thank you for all your help Falko.
    I thought maybe it was me or my glasses or something else i could blame.
    But i gues it might stil be possible this doesn't work with my computer and Xen and ACPI. Oh wel, i go on then without acpi sniff ;-)

Share This Page