Xen Ubuntu VM Install Question

Discussion in 'HOWTO-Related Questions' started by witless1, Apr 28, 2006.

  1. witless1

    witless1 New Member

    Hi, I have followed the Howto on Xen in order to install xen (I installed the binary version from page 2 of the Howto) My Linux knowledge is limited so I will have to tell a big story to explain it :)
    Everything went grand. I installed it initially on a Debain system and successfully followed the instructions to create a Debian virtual host, I could log in and generally do everything and anything i wanted within it.
    However, I needed to install a Ubunutu image on the server. I found another Howto http://docs.anykey.se/xen-ubuntu/using-xen-tools-and-creating-virtual-machines/
    which detailed how to install the ubuntu system via xen-tools.
    This would not work for me no matter what i tried, it always failed on the
    debootstrapping part.
    So, i decided to wipe the hard drive and go again. This time i started with Ubuntu, and followed your excellet walk through once more to get Xen installed.
    Then i switched to the second walkthrough and i managed to get a Ubuntu
    domain up and running.
    However when i log in to this domain i get this error message:
    -bash: no job control in this shell
    I cannot use a lot of the tools so i am attempting to get them via apt.
    When i run any apt command i am getting a Failed to Fetch message and the
    error code (101 Network is unreachable)

    Here is the output of my ifconfig on the vm01

    root@vmubuntu1:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:16:3E:75:2A:95
    inet addr: Bcast: Mask:
    RX packets:2313 errors:0 dropped:0 overruns:0 frame:0
    TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:160854 (157.0 KiB) TX bytes:1048 (1.0 KiB)

    lo Link encap:Local Loopback
    inet addr: Mask:
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Could anybody help me out with this problem?
    Or if that is too much hassle perhaps point me to a walkthrough for a Ubuntu
    virtual machine install (It needs to be Ubuntu of any version)
    Thanks and Regards.
  2. falko

    falko Super Moderator Howtoforge Staff

  3. witless1

    witless1 New Member

    I will try that and let you know my results.
    Instead of debootstrapping to the debian instalation, I will try a ubuntu source.
    If anybody has tried this could they please advise meof success/pitfalls please.
  4. falko

    falko Super Moderator Howtoforge Staff

    Yes, that's the correct way. :)
  5. witless1

    witless1 New Member

    That Ubuntu system worked after all, however after all my hard work to get it sorted, we now need to switch back to a Debain system.. doh :(
    Anyway, i have one more question i am hoping someone can help me with.
    I have created 4 domains, and on the booting of the fifth i get this error message:
    Error: Device 769 (vbd) could not be connected. Backend device not found.

    So i went to the /boot/grub/menu.lst and added the line regarding the max_loop
    value as stated in the howto and i rebooted. However my 4th domain and any others i try to boot still return the same error.
    Could there be any other configuration i need to add?
  6. falko

    falko Super Moderator Howtoforge Staff

Share This Page