Zimbra on Ubuntu, please help me with 2 problem

Discussion in 'HOWTO-Related Questions' started by owl700, Aug 12, 2007.

  1. owl700

    owl700 New Member

    Hi, i have installed Zimbra on Ubuntu thanks to Howto :)
    Now i have 2 problems:

    1 - If i have understand right Zimbra don't request mta/smtp user authentication when you send emails via smtp with a client in local network with Zimbra.
    es. zimbra server stmp ip
    email client ip
    Is this right?
    How can i force mta/stmp to authenticate a client in local network? I have seen that if you use a fake user with a fake domain you can however send emails... why?

    2 - Zimbra use external dns servers also for delivery local mail? I don't have a dns server, for now, to add an A and a MX record for my test domain. There is a mode to tell zimbra to delivery local mail without a record mx?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) run the command:

    postconf -e 'mynetworks ='

    and then restart postfix to deny relaying for clients in your network without authentication.

    2) Add a line like this to the /etc/hosts file on your server to override external DNS settings: yourdomain.com
  3. owl700

    owl700 New Member

    I thanks you a lot! Now i can authenticate local network :))))))))))
    But i try the fase 2 of your halp and i still no recevice local mail, i think i have do a mistake.

    My hosts localhost.localdomain localhost mail.domainname.com mail

    i have modified in localhost.localdomain localhost mail.domainname.com

    but still no local mail arrive

    Can you help?
  4. thanis

    thanis New Member

    Hi, Zimbra definitely needs a DNS Server as it requires an A- and an MX-record. Since you do not have a DNS domain yet (I presume), I would suggest installing a local DNS server (e.g. BIND) and then configure your own domain there.

    After installing and configuring Bind (setup forwarders to your ISP's dns!), just edit the /etc/resolv.conf file and point it to or your server's IP address.

    Also, remove the lines in your /etc/hosts as they will only cause confusion and other errors later on !

    Kind regards,

Share This Page