15 Postfix With SMTP-AUTH And TLS Setup

Discussion in 'HOWTO-Related Questions' started by Lemmiwinks, Jun 20, 2010.

  1. Lemmiwinks

    Lemmiwinks New Member


    I've been following The Perfect Server guide for setting up and ubuntu server (http://www.howtoforge.com/perfect-server-ubuntu-10.04-lucid-lynx-ispconfig-2-p5) and it has been going smooth until setting up postfix.

    I have gotten through all the commands without issue until the setting up TLS certificates portion.

    When I run the command:
    openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    It asks for a password which it doesn't mention anything about in the guide.

    so I entered an arbitrary password and pressed on. I did leave a lot of the questions it asks about country, company and stuff blank just because that was another part the guide doesn't mention anything about.

    But anyways, It was going well until I had to run the command:
    mv -f smtpd.key.unencrypted smtpd.key
    to which I got the error: mv: cannot stat `smtpd.key.unencrypted': No Such file or directory

    So I'm assuming I messed up something around the password part or just before It. I'm not entirely sure. Any thoughts?

    EDIT: Also do you think I am able to progress with the other parts of the guide without finishing this part of it?
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you see any error messages during all the openssl commands?
  3. Lemmiwinks

    Lemmiwinks New Member

    this is the command that requests a password
    openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    and then Here is the bit that I mentioned before where it asked me a lot of questions.

    are there certain ones that need to be answered and ones that don't? I like to stay as anonymous as possible.

    [email protected]:/etc/postfix/ssl# openssl req -new -key smtpd.key -out smtpd.csrEnter pass phrase for smtpd.key:
    You are about to be asked to enter information that will be incorporated
    into your certificate request.
    What you are about to enter is what is called a Distinguished Name or a DN.
    There are quite a few fields but you can leave some blank
    For some fields there will be a default value,
    If you enter '.', the field will be left blank.
    Country Name (2 letter code) [AU]:.
    State or Province Name (full name) [Some-State]:.
    Locality Name (eg, city) []:.
    Organization Name (eg, company) [Internet Widgits Pty Ltd]:.
    Organizational Unit Name (eg, section) []:.
    Common Name (eg, YOUR name) []:.
    Email Address []:.
    error, no objects specified in config file
    problems making Certificate Request
    [email protected]:/etc/postfix/ssl#
    So yes at the 2nd openssl command I get a error which seems to be tied to me not filling out all the fields.
  4. falko

    falko Super Moderator ISPConfig Developer

    Just press ENTER to accept the default values, don't type a dot.
  5. Lemmiwinks

    Lemmiwinks New Member

    Ok just pressing enter worked for that portion of it. I think you should consider adding that direction into your guide :D

    Here is my next issue:

    [email protected]:/etc/postfix/ssl# /etc/init.d/saslauthd start
     * To enable saslauthd, edit /etc/default/saslauthd and set START=yes
    [email protected]:/etc/postfix/ssl# telnet localhost 25
    Trying ::1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 Lemmiwinks.server.com ESMTP Postfix (Ubuntu)
    ehlo localhost
    250-SIZE 10240000
    250 DSN
    I have not tried to troubleshoot but I am missing:


    In the output for that command.
    I'm checking right now to see if I mistyped something or simply missed something. but if you know exactly what would cause that not to show that would greatly help :D

    EDIT: I forgot to change "START=yes" I did that now but still do not get the AUTH LOGIN PLAIN outputs :[
    Last edited: Jun 22, 2010
  6. falko

    falko Super Moderator ISPConfig Developer

    You can simply copy all the postconf commands from the tutorial and paste them into your SSH client.

Share This Page