2 Small Issues

Discussion in 'General' started by merlynmac, May 24, 2006.

  1. merlynmac

    merlynmac New Member

    Hello I recently installed Fedora Core 5 and ISPConfig. I love it. I'm now on the road for 3 months so I don't have physical access to the machine. I can SSH in and such. I am experiencing 2 problems:

    1) For some reason when I add or make changes to a domain or DNS entry the /etc/named.conf file is changed but the /var/named/chroot/etc/named.conf file is not changed. To "fix" this I simply copy /etc/named.conf over but isn't there a way to have it update the correct file?

    2) When I setup ISPConfig it worked flawlessly from within my internal network ( but from outside when I go to my domain:81 all I get is a blank page. If you want to see for yourself try http://www.dragonhost.net:81. Now if I put in http://www.dragonhost.net:81/login.php I get the login page but when I login I'm directed to another blank page. Can anyone shed some light on this. I'd love to be able to administer ISPConfig while I'm on the road but since I can't really log in unless I either setup VNC or SSH in and use lynx or something.

    Any help would be greatly appreciated.

    Thank you
  2. falko

    falko Super Moderator Howtoforge Staff

    /etc/named.conf is the important file that is read by named when it is started. So that's ok.

    It's working for me...
  3. merlynmac

    merlynmac New Member

    I understand that /etc/named.conf is important but when I was setting up my system and added corian-creations.com then tried to go to http://www.corian-creations.com it wouldn't work until I copied /etc/named.conf to /var/named/chroot/etc/named.conf then after restarting the named service it would work but no new domains would work until I updated the /var/named/chroot/etc/named.conf file with the informaiton in the /etc/named.conf.

    On the second part you said it's working for you? Which is wokring for you...just going to http://www.dragonhost.net:81 or the other http://www.dragonhost.net:81/login.php? When I go to http://www.dragonhost.net:81/login.php I get the login page but when I put in my username and password I am redirected to a blank page. When I go to http://www.dragonhost.net:81 it just loads a blank page for me.

  4. edge

    edge Active Member Moderator

  5. merlynmac

    merlynmac New Member

    OK...I just installed Opera and it works for me too when I go to www.dragonhost.net:81 so the problem there seems to be with Internet Explorer.

    I still would like to know how to get the named.conf issue resolved.
  6. merlynmac

    merlynmac New Member

    OK thanks for all the help so far. ISPConfig is working great in Opera I will play with Internet Explorer to see what setting is keeping me from getting to ISPConfig.

    I've narrowed down my named.conf problem a little further. As it turns out it's not whenever I make a change that the named.conf isn't updating it's only the last change I make that's not making it to the /var/named/chroot/etc/named.conf file. I found this out after adding 3 more domains...first was kjorchards.com then premier-planners.com then scotthinkle.com. kjorchards.com and premier-planners.com work fine..it's only the last domain scotthinkle.com that didn't update. To get it working I copied the /etc/named.conf file over...that was the only entry that was missing when I did a diff /etc/named.conf /var/named/chroot/etc/named.conf. Can anyone tell me why the last domain wouldn't have been added? If not no biggie I'll simply keep copying but I'd love to have my system working perfectly.

  7. falko

    falko Super Moderator Howtoforge Staff

    Maybe you can try to create a symlink like this:
    mv /etc/named.conf /etc/named.conf_orig
    ln -s /var/named/chroot/etc/named.conf /etc/named.conf
    That way whenever ISPConfig tries to update /etc/named.conf, it writes to /var/named/chroot/etc/named.conf. :)

Share This Page