Discussion in 'General' started by The General, Dec 28, 2009.

  1. The General

    The General New Member

    Need some help and quick !!!!!! LOL

    when i select a datadase i get the error "error_no_view_permission", please can you tell me why this has started to happen? I have had no changes to the server is this a bug?
  2. The General

    The General New Member

    as a update i can't create databases as well ! as i get the same error if i delete the database it just stays in database window, effectively undeleted
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Tell us what you did before and then we might be able to tell you why that happened. E.g. you might have manually edited a system user or group in ispconfig or you deletec the client that owns the database.

    To delete the database, login as admin and then delete the db.
  4. The General

    The General New Member

    Hi Till

    i have not removed, deleted, or amended anything. the only thing i have done is rebooted the server. is there a way i can recreate permissions?
  5. The General

    The General New Member

    This is strange !

    this is very wierd! i have now got full access again.

    I will report back to this thread if anything changes or becomes more obvious, or unless you can give me a idea what could change overnight that could recreate permissions?
  6. Dreamz

    Dreamz New Member


    Hi posters!

    I was administering email addresses in ISPC3, deleted a couple of accounts and then I also received the 'error_no_view_permission' error when I tried to create a new account.

    This is the same result when trying to do any mail-related administration: Add domain, mailbox, alias etc...

    ..when I try to add a new user, it simply edits the 'admin' user, thus I cannot add a new user.

    Does anyone have any pointers to get me started? Perhaps I can wait for magic too? Lol...;-)

    (, ubuntu 8.10)

    Recent activity (since last working) : PHPMyadmin administration, Joomla / Drupal installs on a site, nothing 'directly' connected to ISPC3.

    Edit: Feeling this is most likely related to deleted email account(s) - as I can't delete any more... can removing an account - eg an account used as a admin / catch all cause this?
    Last edited: Jan 9, 2010
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Where did you add a new user? You are aware that you can not add new ispconfig users under system? Users added manually there will have no view permissions as they miss a client record. You always have to add a new client which creates a new system user automatically.

    No. There is no such thing as a dmin email account in ispconfoig 3.
  8. Dreamz

    Dreamz New Member

    Cannot add client

    Thnaks so much for the reply till :)

    Unfortunately, now I cannot add a client - it has the same effect of editing the first client.

    By admin mail, I was thinking of an email account of the FQDN, but I thinking that was the bad idea that might have caused the problem, lol (making a site for the FQDN, then an email address for the admin user of ISPConfig3 and deleting it in ISPConfig3, perhaps along with ISPConfig3's association with the administrator / group?).

    I've decided to perform an uninstall and re-install of ISPConfig3 and I will post the outcome to confirm it was that (*imagines chips being stacked high in casino*) :)

    Note: Have gzip of /var/www, /var/vmail and MySQL db's (but will reconfigure accounts in ispconfig database from new version, of course!).

    Sorry for wasting your time :)

    Regarding OP, perhaps this original error was related to the system user / ispconfig admin relationship then, which was restored by a change in the system / restart of a service?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Login as admin user and not as reseller.
  10. Dreamz

    Dreamz New Member


    ...I was logged in as admin.

    So, I uninstalled ISPConfig3, reinstalled - still the same error, cannot create a new client:


    This is obviously a problem outside ISPConfig3...
  11. Dreamz

    Dreamz New Member

    Commercial Support

    Till, can I hire you to have a look at the ISPConfig3 reinstall and see if we can find the cause of this error? Do you have time?
  12. Dreamz

    Dreamz New Member

    Complete Reinstall

    Reinstalled totally (Ubuntu 9.10 this time instead of 8.10), working config now. Thanks for the help :)
  13. Dreamz

    Dreamz New Member

    Have successfully recreated the problem

    Created a database and installed ***fengoffice***.

    Now all previous behaviour has returned - loggin in as admin.

    * Adding a domain results in seeing (editing) the first domain on the list.

    * Adding a mailbox results in:


    Will start to look at fengoffice's install script.
  14. Dreamz

    Dreamz New Member

    Have successfully removed the problem

    Needed to restart mysql:

    /etc/init.d/mysql restart

    after installing FengOffice (aka OpenGoo) - I'm assuming it made modifications to mysql which required restart and affected ISPConfig3's operation on the database.

    Will only post back if there are any problems. Hope this helps anyone as silly as me :)
  15. Turbanator

    Turbanator Member HowtoForge Supporter

    Were you successful in installing FengOffice with ISP3?
    Just curious as I'm about to install in on my Fedora 13/ISP3.

  16. Dreamz

    Dreamz New Member

    Hi Turbanator,

    I think what happens is that a database connection/s is/are left open by Feng Office and ISP3 is unable to connect.

    I have found, on the versions I used, that I had to log out of Feng Office in order to use ISP3.

    As long as the you are not logged in to Feng Office on the system when you try to log in to ISP3 with, I think all will be ok :)

    Good luck Turbanator!

Share This Page