403 error after ssh root login to make changes in /web folder

Discussion in 'Installation/Configuration' started by ariban99, Jun 14, 2015.

  1. ariban99

    ariban99 Member

    i following this installation https://www.howtoforge.com/perfect-...l-php-pureftpd-postfix-dovecot-and-ispconfig3 and everything was working great till i need to login to ssh and untar a big website file that i brought in from another server
    i did not have a way that i know of to login via ssh using the clients i created in ispcofing so i logged in as root user, i navigated to the web folder and untared the file.
    after i did this i tried login in with the ftp account created for the client and it does NOT show any of the files, it gives an
    Command: CWD web
    Response: 550 Can't change directory to web: Permission denied
    Error: Failed to retrieve directory listing
    however in ssh as root i see the files there.
    also after this when i go to the website i get a 403 forbidden error

    does anyone have any idea how to fix this?

    also is there a way to add ssh users for specific clients without using root and that client can only access the /web of his domain?

    thank you
    Last edited: Jun 15, 2015
  2. NginxHolic

    NginxHolic New Member

    1. My best guess is this is permission problem. FTP run with different user/usergroup than the file has.
    2. What type of PHP module do you run there?
    3. The easiest way to add specific ssh account for specific web is using ISPConfig panel-> Sites -> SSH Account
  3. ariban99

    ariban99 Member

    thank you for your reply and help. somehow today it just started working again. i read another post someone had a similar problem and it was do to that fact that he tried to update the os within ispconfig, which i tried as well and his also started working again after a while like mine, so maybe it was that!
    also for those like me out there new at this, dont forget to open port 80 on your router to point it to your server!

Share This Page