A bug with Mod-PHP and Custom php.ini settings

Discussion in 'General' started by autogun, Feb 25, 2011.

  1. autogun

    autogun New Member


    A website Im hosting is running on Mod-PHP.
    I've tried adding "memory_limit = 256M" to custom php.ini settings under Options tab.
    This exactly configuration worked on Fast-CGI running website.

    After checking website.com.vhost file, I noticed:
    # mod_php enabled
    [B]# PHPIniDir /var/www/conf/web9[/B]
    Which was still commented out

    Did another change to this website using the control panel, just to make sure new configuration is applied, .vhost file changed its time stamp but PHPIniDir left commented out.

    Manually removed the comment, reloaded apache and it worked! Did another change to the website using control panel, waited 1min and the comment was back on :(

    Running Debian 5.0.7
  2. mike_p

    mike_p Member

    Yes, it does appear to have the '#' in /usr/local/ispconfig/server/conf/vhost.conf.master
    Perhaps that has been left in by accident after testing?
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats no bug. It is intended that the line is commented out as this kind of configuration does not work for mod_php when you have more then one vhost on a server that has this configuration line in the vhost file. If this line is active in a second vhost, then apache will not start anymore. The reason for that is simple, php can load only one configuration per process, as all websites with mod_php share the same process, there can only be one php.ini for all mod_php websites.

    The custom php.ini settings are only for php-cgi, php-fcgi and suphp as explained in the manual, chapter For mod_php, use the php_admin_flag and php_value options of the mod_php module in the apache directives field.
  4. autogun

    autogun New Member

    Hello till,

    Thank you very much for clarifying this to me, I know this is my fault - not reading the manual.

    Just a little suggestion, there is plenty of space under the "Custom php.ini settings" where this can be pointed out. Something like "Works only with php-cgi, php-fcgi and suphp - refer to the manual for more info" or something alike.

    Thanks again!

Share This Page