Access errors with FTP and / stats page - FTP 503 and Http 403 error

Discussion in 'Installation/Configuration' started by Maurizio Paolo, Jul 14, 2020.

  1. Maurizio Paolo

    Maurizio Paolo New Member

    I installed ISPconfig. I made all the necessary settings but I have problems with FTP access and the statistics / stats page.

    With FTP access I have the following error:
    331 User MyUser OK. Password required
    Comando: PASS ********
    Risposta: 530 Login authentication failed

    I also tried to connect as an SSH and ispadmin user but the usual error always appears.
    I have also replaced the password of the mysql.conf file with the one present in the file but the error persists.

    When I try to access the / stats page I get the error 403 (you are not authorized).

    Do you have any idea how to fix it? Thanks so much.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Ensure that your ISPConfig installation is right, see perfect server guides for detailed step by step instructions.
    2) Ensure that you use the right FTP mode in your FTP client, it must be FTP or FTPS and not SFTP.
    3) Check that you use the correct FTP username incl. prefix as shown in ISPConfig FTP user list. also upper/lower case matters for an FTP user.
    4) Do not try to create a FTP user with the same username of an SSH user that you might have created manually on your server.
    5) And of course, use the right password :)

    This can not work as the ispconfig admin user is not a SSH user.
  3. Maurizio Paolo

    Maurizio Paolo New Member

    Thank you for your answer. I'll update you on the checks I made:
    1. Installation - I was unable to install Jailkit. I installed it after installing ISPconfig. Will this be the problem? Do I need to update ISPconfig somehow?

    2-3-4 I checked the settings and they are all right.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. You must do an ispconfig update and choose reconfigure-services during update to fix that. But it's not related to your FTP problem.
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ISPConfig Perfect Server Guide for Debian Stretch states:
    However, for Debian 10 Buster the Guide no longer states that.
    You have not mentioned what OS that host has nor what version of ISPConfig is installed.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I removed that info as it made not much sense in the way that everything mentioned in the guide must be installed before you install ISPConfig anyway :)
  7. Maurizio Paolo

    Maurizio Paolo New Member

    Thanks for your answers. I'll update you on the problem:
    The ISPconfig version is 3.1.15. The system is Xubuntu 20.

    During the installation I had chosen the PHP7.4 version which provided the following errors, I don't know if these libraries are useful, I believe they are not available for php 7.4:

    E: The php7.4-recode package could not be found
    E: Cannot find any package via the "php7.4-recode" glob
    E: No package could be found via the regular expression "php7.4-recode"
    E: The php-gettext package could not be found

    I tried to update ISPconfig with the command:

    After the crontab upgrade, this error appeared:

    Updating Crontab
    Restarting services ...
    Failed to reload php7.2-fpm.service: Unit php7.2-fpm.service not found.
    Update finished.

    ISPconfig is no longer accessible now. The page shows the following error: 502 Bad Gateway - nginx / 1.18.0 (Ubuntu)

    Thanks a lot for your answers.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ubuntu 20.04 is not supported by ISPConfig yet. But you can download a test version which should work on Ubuntu 20.04 by choosing 'git-stable' as update source in
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a guess regarding your FTP problem as you seem to have not followed one of our install guides, maybe you installed pure-ftpd instead of pure-ftpd-mysql
  10. Maurizio Paolo

    Maurizio Paolo New Member

    Thank you very much,

    maybe I solved the problem.
    I installed the 'git-stable' version of ISPconfig.
    FTP now seems to be working. I still have no files on the site. Now I try to install Wordpress and see if everything works.
  11. Maurizio Paolo

    Maurizio Paolo New Member

    Unfortunately the problem is not solved, now it seems that the connection is established but I cannot read the contents of the folder. The FTP log is as follows:

    Status: Connection established.
    Waiting for the welcome message ...
    Status: TLS initialization ...
    Status: Certificate verification in progress ...
    Status: TLS connection established.
    Status: Signed in
    Status: Reading folder list ...
    Command: PWD
    Answer: 257 "/" is your current location
    Command: TYPE I
    Answer: 200 TYPE is now 8-bit binary
    Command: PASV
    Answer: 227 Entering Passive Mode (--,--,--,--,130,82)
    Command: MLSD
    Error: Connection timed out after 20 seconds of inactivity
    Error: The contents of the folder could not be read.

    Do you have any idea?
    Thanks so much
  12. till

    till Super Moderator Staff Member ISPConfig Developer

  13. Maurizio Paolo

    Maurizio Paolo New Member

    The problem should be solved. I opened some Firewall ports as indicated in the link.
    Thank you very much.

Share This Page