After update to 3.1 all sites point at one domain

Discussion in 'ISPConfig 3 Priority Support' started by bmurfin, Nov 17, 2016.

  1. bmurfin

    bmurfin New Member HowtoForge Supporter


    I have a server running Ubuntu server 16.04.1 and ISPConfig 3. I have the DNS records on my own separate nameservers that I maintain using Webmin.

    I just updated ISPConfig and I also pointed a new domain to the server and set up a wordpress site at Now the other seven websites that I host on this server all point to For example, one of the domains is and now it points to the wrong web folder.

    As I try different changes it is hard to know if they have any effect. I have been deleting the web browser cookies after each change. So far I have been unable to diagnose the problem. If anyone has any ideas, I would greatly appreciate it.
    Thanks in advance for any help,

  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    Did you mix * and IP in the webdomains`?
    bmurfin likes this.
  3. bmurfin

    bmurfin New Member HowtoForge Supporter

    Oops! Yes, I did. I just changed all of them to the same ip address and now the correct websites come up when I use a different computer and browser, and preface them with 'www'. is still going to the wrong address but hopefully that will be a minor fix.

    Even after deleting the cookies it seems the old settings are cached somewhere.

    Thanks a million! I have been poking around in all the apache2 files, etc. and you have solved part of the problem.
  4. bmurfin

    bmurfin New Member HowtoForge Supporter

    Problem solved, (I think): I just used incognito mode in Google Chrome and all of the websites worked fine. I changed from ip addresses to * in the web domains setting.

    For some reason, both Google Chrome and Firefox cache the sites and make it very difficult to test to see if the websites are functioning properly.

    Thanks for your help,


Share This Page